0

So I'm using Pages on my Mac and I once was able to switch the windows (NOT the application, but the windows in Pages) with the shortcut command + < or command + >. Now, they apparently removed this function.

new shortcuts

In other applications like Safari it does still work. Do you know how I can activate this function again?

Thanks in advance!

  • What keyboard layout do you have? – 0942v8653 Dec 8 '14 at 18:22
  • @0942v8653 It's german. – LinusGeffarth Dec 8 '14 at 18:38
1

It looks like Pages overwrites the command + < shortcut to zoom out the view even though that's the default shortcut for moving focus between windows on a German keyboard.

pages menu

You can go in to System Preferences -> Keyboard -> Shortucts to redefine that shortcut in Pages. Click App Shortcuts, click the + button, select Pages from the Application list, enter your equivalent of "Zoom Out" for the menu title, and enter a new keyboard shortcut.

Entering a keyboard shortcut

In my example, I assigned command + back tick to Zoom Out and now in Pages that shortcut zooms out the view instead of switching windows.

  • No. Doesn't work either. In every other mac apps it does work with both – LinusGeffarth Dec 8 '14 at 18:12
  • I'm assuming a US keyboard layout, which may be a mistake on my part. What language is your keyboard? – SSteve Dec 8 '14 at 22:08
  • As I said before, my keyboard layout is german – LinusGeffarth Dec 8 '14 at 22:18
  • I'm sorry. I see now that you answered that question after I posted my answer. I'll update my answer. – SSteve Dec 8 '14 at 22:27
  • 1
    You want the Zoom out shortcut to be something other than command+< so that it doesn't conflict with the system wide command+< shortcut. It my example I set the shortcut to command+back tick to illustrate that the Pages shortcut overrides the system shortcut if they're set the same. – SSteve Dec 9 '14 at 18:49
0

⌘` (command + backtick) definitely works, on both the old (’09) Pages and the new. ⌘< and ⌘> (remembering to hold down shift to get < and > on my keyboard) zooms in/out on both versions.

If ⌘<,⌘> used to switch windows for you, you must have redefined them, either in System Preferences→Keyboard→Shortcuts or in some third-party macro utility (Keyboard Maestro et al.). Re-check your shortcuts and see if they're still defined.

If ⌘` no longer works, look in System Preferences→Keyboard→Shortcuts→Keyboard and see if you've disabled or remapped "Move focus to next window", which by default is enabled and mapped to that key combination.

Bear in mind if you've using Spaces that ⌘` only switches to the next window of the same application in the same Space. It will not switch to a window in another space, nor a window that has been minimized (because minimized counts as a separate Space). Nor will it switch from a window that is using full screen (because such a window is the only window in its Space). Clicking on the app's Dock icon will switch to the next Space that has any open windows for that app (and you can then cycle between just those windows). Minimized windows can be found in the app's Dock menu, or using Mission Control.

  • Well the thing is that I never changed any shortcuts. And in the system settings it says "Move to next window" is still defined as it should be and it works for all other applications. In the pages-settings there is nothing to configure this. I saw that Pages was updated. So I will try your way and tell you if it worked – LinusGeffarth Dec 8 '14 at 21:09
  • hm command+` does not work either for me... – LinusGeffarth Dec 8 '14 at 22:11
  • Are you sure you have another window to switch to? Have you checked to see if ⌘` has also been assigned to a different shortcut? – ganbustein Dec 8 '14 at 22:21
  • Yes, and yes I did – LinusGeffarth Dec 8 '14 at 23:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .