I got a new iMac and I'm trying to install Adobe Photoshop CS3. I'm using the original install disk, but when it gets to the end of the installation it says that the Shared Components were installed successfully but Photoshop CS3 failed to install. I contacted Adobe, but they only support CS4 and CS5 now, so they won't help me. I've searched the web and followed a bunch of suggestions, but nothing is working. I'm hoping you might be able to help me.

I've tried:

  • Used Disk Utility to repair permissions on my disk
  • Used Adobe Cleaner Tool to ensure that no partial installations are present
  • Copying the install directories to local disk and installing from there

I really don't want to fork over more money for CS5 since I already purchased CS3. Any ideas?

  • You aren't running a case sensitive filesystem are you? Jun 15 '11 at 4:58
  • I'm pretty sure it is case-sensitive, because UNIX is case-sensitive. Not really sure why that should matter. Jun 16 '11 at 16:32
  • By default hfs+ is not case sensitive but you can install it that way. Adobe products will not install on a case sensitive filesystem. - that is why I asked. Jun 17 '11 at 3:42

It turns out that my RAM was faulty. I replaced it and the install worked just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .