2

Since this morning, the "swipe between pages" functionality doesn't work anymore on my computer!

Web-browser specific description of the problem

Google Chrome

When I try to swipe between pages on Google Chrome, it just does not work. The window get shifted within its frame and come back to its original position.

Safari

When I try to swipe between pages on Safari, the window slightly shifts within its frame and get stuck into this position. Further two-finger movements (including scrolling up and down) are then not functioning. When I open a new window, the scrolling up/down is working again.

Firefox

When I try to swipe between pages on Firefox, nothing happen and further two-finger movements (including scrolling up and down) are then not functioning. When I open a new window, the scrolling up/down is working again.

How I tried to solve this issue

I opened system preferences to make sure that in the section trackpad, the option swipe between pages is activated. Yes, it is activated!

For some reason, I checked the always box next to Show scroll bars in the general section in the system preferences.

In Bash, I wrote the following command line: defaults write -g com.apple.trackpad.scrollBehavior 2 but nothing happens!

  • If the system does not accept your settings, then try to repair the permissions in disk utility. – Ruskes Dec 7 '14 at 20:11
0

Try logging out and back in.

I know that sounds like a "grasping at straws"-type solution, but this is the sort of doesn't-make-sense kind of problem that I've seen fixed by logging out (or maybe even restarting).

  • Why didn't I try that before? That solved my problem. Thank you for your help! – Remi.b Dec 7 '14 at 20:17
2

What worked as well for me was switching off two finger swipe from the trackpad settings ('Swipe between pages' setting), then turning it on again directly after. A lot more convenient than logging out and in again.

Swipe between pages setting

If the problem happens too often a PRAM reset often helps as well:

  1. Shut down your Mac.
  2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
  3. Turn on the computer.
  4. Press and hold the Command-Option-P-R keys before the gray screen appears. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
  5. Release the keys.
  • 1
    This worked. Only changing to 3-finger swipe and back was not enough, the checkbox must be unchecked and then checked again. – jmiserez Jan 19 at 7:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .