1

I used to backup my data via Airport Time Capsule and configured my backup, so that no Applications are part of the backup. In case of a broken HDD etc. I would prefer to install only those applications I really need and not all the other legacy crap which comes with the time...

Now the time has come and I've got a "new" (late 2012) Macbook Pro. I powered it on and set it up just as usual. After the first boot I opened the Migration Assistent in order to recover my backup from the time capsule. Somehow nothing happened after entering the APT credentials for my Account, so I tried it with the CMD+R mode during the boot process.

This worked just fine. I entered my credentials and the recovery process began. After completion the MBP restarted and I had a normal desktop with all my files. My backup recovered.

Unfortunately now there is no "Applications" directory in my User dir. There are also no applications like "Safari.app" or even "System Preferences.app". When I try to change the Desktop Background (which I thought would open the System Preferences) nothing happens. All Dock-Items are represented by an "?" - except Finder which seems to be the only app which is still there.

I booted the system via CMD+S in order to search for those applications. find . -name "Safari.app" had no results. As a proof that find works I searched for a file I know that exists in my backup: find . -name "certain_file.jpg" and I had a correct result. I don't even have a terminal (except the CMD+S shell).

The MBP was shipped with OS X Yosemite and apparently the system recovered without any Applications. Edit: it's Mavericks, not Yosemite. -> there is still a Recovery HD.

What now? How can I get at least all my standard applications?

1

Not everything makes perfect sense, but I believe this set of instructions will help you along.

Review the entire articles below:

Outline of the process:

  • make sure the backup is safe and doesn't get erased. Also, be sure to not back up to this volume until your new OS has all the data you need since a new backup could cause older backups to be erased.
  • boot to recovery mode and open disk utility
  • erase the hard drive on your Mac
  • install a clean copy of Yosemite
  • make a test account (user name test-admin or something that isn't the name you used on the backup Mac)
  • update all software on the Mac
  • then connect the backup and use the Migration Assistant to move users and data. (you could move apps here too if you have any backed up)
  • reboot and log in to your "old account" instead of the test-admin account
  • verify the apps and data are there
  • then, connect and make a back up of the fixed Mac
  • delete the test-admin account and remove the home folder
  • enjoy your success
  • It would take me more than your 14 minutes to type all that :) – Ruskes Dec 7 '14 at 18:55
  • For some reason it was enough to follow the first step. I just reinstalled using CMD + R. My Account was still there, my data also - plus all the standard applications. No need to do a separate backup restore. Thanks a lot! – cvoigt Dec 7 '14 at 20:57
  • @cvoigt Super Bonus - glad a simple reinstall was all you needed to get back in business. – bmike Dec 8 '14 at 0:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .