8

I'm trying to get Silverlight to work on Mac OS X, any browser would do. I'm not getting much success at all so far, nor help from the Web.

1) Silverlight + Mac OS X Yosemite

To start with, can anyone tell me if this Silverlight test works for them on Mac OS X Yosemite (10.10.1) ?

http://www.microsoft.com/silverlight/iis-smooth-streaming/demo/

This should offer a menu and various content, mostly pictures. (As opposed to a big black square of nothing.)

2) Troubleshooting

I'm using a MacBook Pro from Mid-2014. I had Silverlight version 4 installed before but never got it to work (I don't know if this was before or after my Yosemite update.)

I've tried uninstalling and re-installing Silverlight but without success.

To install, I'm merely using the Silverlight.dmg file and its installer to install.

Here is what I'm getting so far:

  • In Firefox: the official "Get Silverlight" page tells me the plugin is installed ("Silverlight 5 (5.1.30514.0)"), however the test page linked above renders black. FYI, the plugin is set on "Always activate" in about:addons and disabling AdBlock did not help.
  • In Chrome: I had to use the "Get more extensions" option inside of Chrome to install. However, the test linked above merely offers an "Install Microsoft Silverlight" icon.
  • In Safari, the test seems to render okay but then I get an error from Safari itself: "A problem occured with this webpage so it was reloaded", leading to the page being reloaded automatically until Safari gives up and tells me that an error repeatedly occured with the page.

Any pointer welcome.

  • 2000 views an not a single comment? I'm having the same problem on a brand new iMac. The problems are verbatim, (in all 3 browsers). Anyone have any sort of solution?!? – dprogramz Jan 20 '15 at 20:36
  • I've the same issue. Any luck so far? – IceMan Jan 27 '15 at 4:45
  • 1
    A quick update: with Silverlight 5.1.40416.0 installed, it now works in Safari (the test above does). Things stay the same for Firefox and Chrome though. – Fabien Snauwaert Jul 9 '15 at 15:52

11 Answers 11

4

Under Safari/Preferences/Security click the last box that states "Internet Plug-ins: Allow Plug-ins"

So simple and it worked for me running Safari on 2008 MBP with OX X Yosemite

  • 1
    That option is already checked (don't know if this was the case at the time of my first post). Also upgraded to Silverlight 5.1.40416.0 in the meantime and it now works. – Fabien Snauwaert Jul 9 '15 at 15:54
  • same problem here – grepit Aug 7 '15 at 23:12
1

I have been using some applications in the latest version of Yosemite with Silverlight and with Safari and never had any issues so I'd believe that this might be related to the application you're running on Silverlight.

0

I decided to look into uninstalling Silverlight which led me to your comment. In my efforts I decided to reinstall and try uninstalling again. Since I just reinstalled I decided to try your link. I got the black box like you did with a little imposed box in the top left corner with silverlight printed in it. I clicked the little box and the big black box a couple of times, since I use click to plugin extension, and it loaded fine. Good Luck to you

P.S. I am using a mid-2011 MacBook Air running Yosemite 10.10.2

0

I have been having the exact same issue on my Mid-2014 MB Pro. I am almost positive the problem does not lie in Yosemite itself but rather in the new machines. Apparently new machines were formatted differently or something of the sort and no longer support Silverlight whereas older machines that simply upgraded to Yosemite from something even as recent as Mavericks do not have this issue. I work at an Apple Premium Service Provider and have spoken at length with Apple certified technicians on this topic and that's our conclusion. It sucks, really.

0

Perchance, make sure to select Run in Unsafe Mode in Safari Preferences for this plugin. Works for me on Fidelity Investments website for their Silverlight realtime trading tool.

  • ...in 10.10 beta through production releases through 10.10.3 second public beta, on all my macs, including Mac Pro Late 2013, 5k Retina iMac, 2014/13 Mac Book Pros, 2014 Mac Book Air, early 2009 3.06 GHz built-to-order 24" iMac 9,1, and so on through used older Mac Book pros with Yosemite upgrades.. – user119123 Mar 22 '15 at 10:26
0

This worked for me in running Fidelity ATP with Firefox, not Safari:

Find the Microsoft Silverlight alias in Applications, double click to open Microsoft Silverlight Preferences.

In the Application Storage tab, Delete All (lower right)

Enable Application Storage should be checked.

Quit Silverlight, restart Firefox.

0

Make sure that the following is set:

  1. Go to Safari Preferences - Security

  2. Tick Internet Plug-ins box and Click on associated 'Plug-in Settings'

  3. Make sure all Plug-ins in the list are Ticked

0

I just had the new operating system installed and was unable to install silverlight. The technician told me to go to systems preferences and hit the general tab. About 1/2 down, if you have already tried downloading silverlight, it should say apple store and identified developers. Click that button and then click always. It will step you through the process to download silverlight.

  • 1
    You are referring to System Preferences > Security & Privacy > General, not System Preferences > General. The setting is called Gatekeeper. – tubedogg Nov 8 '16 at 1:02
0

In Safari's preferences, under the 'Websites' tab, I found these settings for the silverlight plugin. I changed both the dropdown settings to 'on', and now silverlight works for me. enter image description here

-1

I had the same problem also but found that under Safari → Preferences → Advanced → Internet plug-ins I had checked stop internet plug-ins to save power. Apparently applies even if you are off battery power.

-1

go to firefox plugins https://www.google.de/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=firefox+plugins+how+to+open then check if silverlight is enabled. it worked for me on a new mac with 10.10.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .