I'm currently using a Cooler Master Quickfire Ultimate keyboard that works perfect with Windows 7. However, whenever I have it plugged into my Macbook pro (running OSX 10.9.5), the default mappings don't seem to work.

I've used other keyboards, and the windows key will always re-map to cmd on mac. However, on my new keyboard, this isn't the case. The windows key doesn't seem to do or change anything. The alt key also doesn't seem to get mapped to anything initially.

My ctrl key maps correctly to ctrl on mac, but this leaves me without a command, or an option key.

I went into the "Modifier Keys" panel, and selected my keyboard on the list. Changing command to map to the ctrl key does remap cmd from mac to ctrl on my windows keyboard. Changing the mac ctrl to map to whatever the default "cmd" key is (in this case, should be the windows symbol key), does not work.

This means, when I'm trying to run a program and have to execute commands with the mac ctrl, I have to keep switching the modifier keys around.

I've tried using karabiner to remap keys, but can't seem to figure it out. I looked on the XML key list, but can't figure out how to remap the windows key to the mac ctrl, and the command key to the windows ctrl. How would I go about fixing this?

  • You should post your edit as an answer below. That gimmicky "gaming mode" thing… eugh…
    – 0942v8653
    Commented Dec 7, 2014 at 3:03

8 Answers 8


I fixed the issue!

Turns out that on this keyboard, doing fn + f12 actually disables the windows key. This was turned on by default. This is why nothing was working when I would press the windows key. I pressed fn + f12 again and now everything works :| weeks of frustration all due to me not looking at my keyboard layout :(

  • 1
    ARGHH, thanks! Do u also have a cmstorm trigger-z!? :) Commented Jun 21, 2015 at 2:06
  • 1
    You just saved me a few weeks of frustration and the price of a new keyboard. Thanks!
    – cggarvey
    Commented Jun 8, 2018 at 16:18
  • 1
    For me, it was f11 instead of f12. Commented Dec 17, 2018 at 10:18
  • 2
    Same thing on my MaxKeyboard Nighthawk X7 keyboard. I think on my keyboard it enables "gaming mode".
    – Adam
    Commented Mar 20, 2020 at 2:49
  • 1
    I had the same issue with a HyperX Keyboard! I am really grateful for the answer.
    – CTala
    Commented Apr 11, 2023 at 18:43

With my Durgod keyboard it was the Fn + Windows combination to lock/unlock the windows key to switch it to the command key.

  • Same here with a Tesoro Gram Spectrum running through a KVM.
    – Ajar
    Commented Sep 11, 2020 at 18:16
  • This is the same for the Varmilo keyboards.
    – Biketire
    Commented Aug 9, 2023 at 12:41
  • My goodness thank you I almost broke down my keyboard for heavens sake.
    – Roy
    Commented Feb 21 at 20:58

For some Logitech keyboards, Game Mode is controlled by a physical toggle with a joystick on it.

Pretty sure my kitten bumped it. The scamp.

But yeah, if none of the Fn combos work, look for a physical toggle.

  • Ahhh, thank you. It was the lock button in the top right corner of my keyboard, I hadn't thought that it was key board level switch. Commented Jul 12, 2023 at 16:35

I had a slightly different experience than the others did here. My Windows key wasn't locked -- it simply wasn't assigned in the keyboard's memory. In order to get this to work correctly, I had to download the software for the CM Storm Trigger Z (which should function similar to your Quickfire) on a Windows machine, assign the correct key to act as the Windows key, and then it worked when returning the keyboard to my Mac.

You can find the company's instructions on downloading the software and getting this fixed here, by clicking "Download" and then "Windows Key Setup": http://www.coolermaster.com/peripheral/keyboards/triggerz/

There's one other thing that has to happen before your keyboard will work on OSX correctly: you have to select the keyboard's profile by pressing the storm button and the number 1 at the same time. This activates the profile for which you've programmed the storm key to function as the Super key (Windows key / CMD key).


In my case with Logitech G413 the windows key also stopped working. Fn+F12 didn't help but plain old unplugging the USB cable and plugging back helped.

  • This also solved it for me.
    – joel.d
    Commented Jun 20, 2019 at 17:07

This solution is completely non-intuitive, but it worked for my case.

I have my gaming keyboard (made for Windows) attached to my work MacBook Pro. Previously, the Windows key was seamlessly mapped to the Apple command key without my having to do anything other than plug it in. After several Big Sur updates, suddenly my Windows key no longer worked.

After some experimentation and research, the following was successful.

  • Open system settings.
  • Select keyboard.
  • Select Modifier Keys... button.
  • Set Option Key to Command.
  • Set Command Key to Option.
  • OK

At this point, both my option keys behaved as command keys, and my command key behaved as an option key.

One detail that may or may not be relevant to this solution. On my gaming keyboard, the option keys are in the exact physical position as the command keys on my MacBook Pro, and the left Windows key is in the exact physical position as the left option key on my MacBook Pro.


For Cooler Master Keyboard it's Fn F9 to enable and disable the lock.

For Steelseries Keyboard it's Steelseries Win to enable and disable the lock.


I am using a Nacodex AK510 and had to do fn+Del for 3 seconds to reset to default settings. Supposedly fn+Win toggles it on and off but that was not working for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .