20

I have a brand new MacBook Pro (Retina, 15-inch, Mid 2014). Shipped with Yosemitee pre-installed, the version I have is 10.10.1 . I don't have any software installed except Google Chrome, so it is clean/new OS.

I noticed sometimes the keyboard and trackpad become completely unresponsive after waking up the laptop from sleep. Happened several times, the last time it happened I could not reset PRAM or SMC as keyboard was unresponsive even after restarting or shutting down so I had to Re-Install OS.

Today I was able to reproduce the issue, first I tried to let it go into Sleep mode several times with no device plugged into the USBs, and Lid left opened. I could not reproduce, both were working when I wake the laptop.

Then I plugged in a USB Mouse, left the lid opened, and let it go to sleep for 1 hr. When I waked it up, the keyboard/mouse were unresponsive. Then I unplugged the mouse usb, let it go into sleep mode, and closed the lid .. for few minutes. Then I opened the lid, waked it up .. this time both were responsive and working.

I was able to reproduce the above scenarios, so it is not a random thing.

So, is there some kind of a log or test I can use to reproduce or while reproducing the unresponsive case above so I can understand if it is a hardware or software problem ?

[edit]

You can get the system.log from here https://www.dropbox.com/s/3x320cieum3it4w/system.log?dl=0

Also, here is the result of 'pmset -g'

Active Profiles:
Battery Power       -1*
AC Power        -1
Currently in use:
standbydelay         10800
standby              1
halfdim              1
hibernatefile        /var/vm/sleepimage
darkwakes            0
gpuswitch            2
disksleep            0
sleep                1
autopoweroffdelay    14400
hibernatemode        3
autopoweroff         1
ttyskeepawake        1
displaysleep         2
acwake               0
lidwake              1

[edit 2] Sorry I undo the selected solution as it did not fix the issue, as I have new information, they are unresponsive again and this time I see this keeps showing in the system log, any idea ?

Dec 12 23:49:30 ahmads-mbp kernel[0]: AppleUSBMultitouchDriver::_getFeatureReportInfo - DeviceRequest returned error 0xe00002c0 (interface 1, reportID 0xd9)
Dec 12 23:49:30 ahmads-mbp kernel[0]: AppleUSBMultitouchDebug: _getFeatureReportInfo returned an error in AppleUSBMultitouchDriver::_deviceGetReportWithLookUp
Dec 12 23:49:31 ahmads-mbp kernel[0]: AppleUSBMultitouchDriver::_getFeatureReportInfo - DeviceRequest returned error 0xe00002c0 (interface 1, reportID 0xd1)
Dec 12 23:49:31 ahmads-mbp kernel[0]: AppleUSBMultitouchDebug: _getFeatureReportInfo returned an error in AppleUSBMultitouchDriver::_deviceGetReportWithLookUp

[edit 3]

I managed to downgrade it to Mavericks but problem still happening. I think it is hardware issue now since I was able to reproduce in two OS X versions. So I am taking it to apple store to replace it or fix the hardware.

[Edit 4] Confirmed! it is a hardware issue, I replaced the top case and the problem gone!

  • 1
    Welcome to Ask Different! Good first question, well researched. – Tetsujin Dec 6 '14 at 20:01
  • You could add information on your pmset -g and your console report from the time you wake up the computer. – Ruskes Dec 6 '14 at 20:42
  • @Buscar웃 I updated the question to include the pmset output, and I included system.log report, is this the correct report file ? – Ahmad Alkhawaja Dec 6 '14 at 21:26
  • Great! reading it!, so you use a USB hub ? – Ruskes Dec 6 '14 at 22:00
  • Madrid Spain- was there, I love that city. So while I am looking for the USB problem you could fix another one by following the instructions here ispire.me/fix-yosemite-rtc-alarm-wakeup-issue – Ruskes Dec 6 '14 at 23:11
4

As for me, I, too, faced the same problem with my MacBookPro after upgrading to Yosemite: the keyboard and trackpad would freeze, especially after waking up from sleep. At first, I'd restart the device. A few days ago, out of sheer frustration, as I clicked on random keys and rubbed the trackpad, the keyboard and simultaneously, the trackpad, became responsive, quite to my surprise. After several more tries, it now seems to me the key 'Q' was the key- pressing it several times, along with the 'esc'. I don't know how, but this works on my MBPro. Of course I'm no techie, and have no explanation, but would request interested and affected users to try my approach.

  • Bizarre, but works like a charm. Thanks a bunch! – onnodb Feb 25 '16 at 20:05
3

Analyzing your Console log I came up with:

you have dozens of different problems:

RTC (Alarm)

Follow the instruction here to fix that.

Fix Yosemite rtc alarm wakeup issue

Then you have the remote sharing and Management Enabled- I assume you know about that.

You can see that here:

From Ahmads-MacBook-Pro

to

Dec 6 19:47:32 ahmads-mbp.zte.com.cn configd[25]: setting hostname to "ahmads-mbp.zte.com.cn"

Are you using a zte.com.cn device ?

Still did not find what is going on with the USB, but would recommended:

1- Disable any and all sharing to test.

2- Run permissions repair in Disk Utility.

  • Interesting .. I don't use any device from zte.com.cn, I don't know where that name came from. may be a virus ? :) – Ahmad Alkhawaja Dec 7 '14 at 12:31
  • As for remote management and sharing, it is not enabled, disabled in my both laptops. I have two Macbook pros connected to same network, would it be one of them remotely trying to wake up the other via network ? – Ahmad Alkhawaja Dec 7 '14 at 13:53
  • Also I am not sure if this information is important but I would like to share it. Old macbook name is "Ahmad's MacBook Pro" and the new one is "Ahmad's MacBook Pro (2)". Old macbook name in network is "Ahmads-MacBook-Pro-2.local" and the new one is "Ahmads-MacBook-Pro.local" but I doubt it has anything to do with this bug. – Ahmad Alkhawaja Dec 7 '14 at 13:56
  • I have not tried the rct alarm wakeup fix solution yet. Right now whenever I try to leave my laptop i un-plug everything :) now I have another problem where kernal_test goes banana and consume cpu usages +500. This OS is useless and as a coder I cannot do any useful thing on it, and I cannot downgrade to Mavericks as this machine is pre-installed with Yosemite -_- Thanks for your help! – Ahmad Alkhawaja Dec 8 '14 at 12:18
  • 1
    Actually your computer is in trouble. I would recommend you do the cmd-r and reinstall Yosemite. If you want you can go back to Mavericks but that is another story. – Ruskes Dec 8 '14 at 17:43

You must log in to answer this question.

protected by Community Jul 7 '15 at 12:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .