1

My GF's MBP running on Mavericks broke down 2 days ago. First I tried to copy the contents of her HDD to an external HDD but got the I/O error time after time.

Then I tried all the basic things like repairing the disk in Recovery Mode and try and verify/repair permissions in disk utility, cause I read that that could also help but that didnt do the trick either.

Now I am trying to repair the permissions through the Terminal and getting alot of detailed I/O errors. Also the progress bar is stuck @ 74% now. It doesnt advance only I get every 20 secs or so a new line with a new error. My original plan to try n save the data on the HDD has become too complicated for my skills so I'm in desperate need of help since it has been awhile since last backup.

  • I'd get the drive out into an external USB enclosure, attach to another machine as an external & try to clone it with CCC first; just in case it's dying. – Tetsujin Dec 5 '14 at 21:14
  • In other words, I need to open up the MBP, get the HDD out and attach it to my own PC in the manner you described, and try to clone its contents? – MikeW Dec 5 '14 at 21:24
  • Unless you can get it to fix from Recovery mode - but my hunch is it might be hardware fail imminent, so better safe than sorry. If you had a backup, you could be more cavalier, as you don't, then circumspect is the safest way to go – Tetsujin Dec 5 '14 at 21:26
  • 1
    I'm still not sure it was the wisest move.. & this backs up my thinking, from Linc Davis [very smart cookie who hangs out on the Apple forums] Just a comment: Repairing permissions is by far the most often recommended troubleshooting step in these forums, and by far the least likely to be correct. Under most circumstances it does no harm apart from wasting time, but when you have a damaged storage device, any write operation may make the damage worse and data recovery less likely. Permission repair can potentially cause many thousands of writes. – Tetsujin Dec 6 '14 at 15:56
  • 1
    [cont…] When there's a possibility that your boot device is malfunctioning, the first thing you should do is NOT to repair permissions, but to make a complete backup, without overwriting any previous backup. – Tetsujin Dec 6 '14 at 15:57
1

I found a (quite easy) way to recover the contents of my HDD.

1) I got myself the MBP from my nephew. 2) Connected it with a FireWire cable to mine. 3) Booted our MBP up in Target Disk Mode (press 'T' when booting up) 4) Our MBP then behaved like any external storage device and the files could copied off just like that.

In that way i got all the important files, photos, and projects of the lady. Hopefully this can help people in the future if they are having similar issues.

  • I avoided that, only because I don't know whether it will bypass SMART, which could possibly lock you out. Connecting over USB disables SMART. – Tetsujin Dec 7 '14 at 10:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .