1

I added a CD to my iTunes Library yesterday. I could not find them under Recently Added playlist or under Music. So, I created a Smart Playlist for the Artist and they do show up.

When I choose Artists and Albums, the music is not there. The songs only show up in the Smart Playlist for the Artist.

I have looked in the iTunes folder and the Artist's folder is definitely there and has the album's folder and all of the songs.

I can also play the songs when I click on them in the Smart Playlist (so one of the correct file types to play in iTunes).

I have also closed and restarted iTunes several times and it still does not work.

I opened music on my iPhone last night and noticed that the artist/album/songs do appear in the cloud.

How can I get them to show up in iTunes in the Music/Albums, Artist, Songs lists on my Mac?

Linda

  • Right click on the songs and go to Get Info and select the options tab. Make sure the media type is Music. – Flying Trashcan Dec 5 '14 at 14:43
  • Yes it is. Good try though. – Linda Dec 5 '14 at 16:59
  • Under Get Info, what extension is listed for the files? What are the settings on your Recently Added playlist? – tubedogg Dec 6 '14 at 9:43
  • It solved itself after rebooting my computer. I have a little less than 16,000 songs. Or maybe my computer is getting overwhelmed since it is almost full and has slowed down. (New Mac has already been bought and shipped :-) – Linda Dec 6 '14 at 23:32

You must log in to answer this question.

Browse other questions tagged .