7

Is there a way to change the default volume setting for headphones/line out, i.e. the one you get after plugging a jack in for the first time since you've turned your Mac on and started OSX?

I'm using a 2008 unibody (aluminum) Macbook, running Snow Leopard. And several times I've run the risk of hurting my ears because of that default value (half of the scale).

1
  • my ear hurts. stupid mac
    – WTIFS
    Jun 5 at 9:39
4

Take a look at breakaway. You can write a quick applescript to change the volume back and forth when when the headphone is connected/disconnected, and much more

2
  • thank you very much, this would be a solution, if it weren't for the bug that doesn't let me enable any trigger in the AppleScript plugin... I'm reporting it, hopefully it will be solved soon.
    – fudo
    Aug 19 '11 at 12:09
  • kinda works: I can't really get the AppleScript plugin to work, but since I installed Breakaway the headphones volume is remembered across reboots... I don't really understand, but I'm accepting the answer anyway. Thanks again.
    – fudo
    Aug 31 '11 at 11:23
3

I had the same problem. Setting the volume as low as it could go was still too loud.

Here's a solution that worked for me:

  1. Download Loopback
  2. Set it up so that you have the following:
  3. Sources: Pass-Thru
  4. Output Channels: Channels 1&2
  5. Monitors: [Select your headphone device]

Now all audio is routed to a virtual device, which outputs to your headphones. This gives you an additional volume slider for more fine grained control, which will allow you to set your headphones to be much quieter than you could normally with the default OSX volume options.

1

Open "AppleScript Editor"

Add this line:

set volume 1.5

Then File > Save As

In the file format box choose "Application" and check the "Run Only" box. Name the file and save it somewhere you can find it.

Then if you drag that app into your dock, you can right click it, select Options > Open at Login.

This will set the volume to around 3 boxes of the scale on startup. However it will not detect if you have headphones plugged in or not. It will just always set the volume lower.

8
  • If you don't have headphones plugged in, then plugging them will change volume back to default "half of the bars" :-( Jun 14 '11 at 13:01
  • Thanks for your answer. However, I agree with @Peter: I don't think this really solves my problem.
    – fudo
    Jun 14 '11 at 13:17
  • That's strange. It should be remembering the volume levels. You might need a PRAM reset (this manages remembering volume levels I believe)
    – maclema
    Jun 14 '11 at 13:53
  • support.apple.com/kb/HT1379
    – maclema
    Jun 14 '11 at 13:54
  • @maclema: The thing is, my computer does remember its "basic" volume setting, but not the one for headphones (not across reboots, at least). Do you think that's also managed by PRAM? In other words, does your Mac behave differently? I thought it was a "by design" thing, and asked here looking for some workaround.
    – fudo
    Jun 14 '11 at 14:38
1

Check these values each time before you plug in your headphones.

System Preferences for Sound

Check the box for "Show volume in menu bar." Each time before you plug in any headphones, go to your Menu bar and manually lower the volume.

enter image description here

Trying to solve this problem with AppleScript and the like is severly over-engineering a solution.

3
  • 1
    … thanks, but that doesn't answer my question. I definitely know how to adjust the volume manually, but I wish I wasn't forced to do that each time I use headphones; I still forget sometimes.
    – fudo
    Aug 15 '11 at 18:03
  • 1
    Also, lowering the volume before plugging in headphones, as you suggest, does not work: as I wrote in the question, the first time I plug them in after starting my Mac, the volume is automatically reset to half scale, no matter what the volume was before the insertion.
    – fudo
    Aug 15 '11 at 18:06
  • I encountered a similar problem with a Mac Pro (late 2009) under Snow Leopard, and it would NOT remember volume settings under any circumstances. I remember seeing online that several other users of this same model Mac Pro had exactly the same problem. So I'm sorry I can't provide a definitive fix. Please file a bug report with Apple!
    – user9290
    Aug 15 '11 at 18:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .