4

One of the nicest features of the new OS integration between iOS 8 and Yosemite is the ability to text and receive phone calls from my iPhone while on my Mac.

However, when I work from home, I need to use Cisco AnyConnect to create a VPN network. When the VPN network is active, I can see phone calls from my iPhone on my Mac, but answering the call on my Mac will cause the call to disconnect. Trying to call from my Mac will show the dialog box that I am connecting, but the iPhone never responds. If I am on a call on my Mac, and start up the VPN, the call disconnects.

I have a 2014 13" MacBook Pro and an iPhone 5S both running the latest OS with all the patches.

What is going on, and is there a way to fix the problem?

3 Answers 3

2

Cisco's VPN software typically locks out all local LAN access. In other words, your Mac is no longer on your network. It is now tunneled into your VPN connection.

1
  • Well, that (what's the technical term? oh yeah...) sucks. I bet the Bluetooth network sees my iPhone which is why my Mac can spot it and tell me a call is coming through, but the call itself is handled via WiFi. I used Shimo a while ago when the Mac's VPN wouldn't work and Cisco didn't have a decent Mac client. Maybe I'll give that another try.
    – David W.
    Dec 4, 2014 at 21:27
0

It doesn't depend on the client software that you use (Shimo or AnyConnect) but rather on the AnyConnect Profile used to establish connection. In my case I've got two profiles available (one that routes all the traffic via the VPN server and another one that routes selected subnets only). In both cases iPhone calls continuity fails when VPN is on. With VPN off, everything works.

0

Our company just deployed our first Cisco FTD and we had this issue. I spent a few hours with Wireshark to find out what was happening and found a fix relevant to our situation. We are not assigning any IPv6 addresses through the VPN via a pool, and therefore, by default, all IPv6 traffic is DROPPED by the client when Anyconnect is connected! The iPhone dialing works via mDNS (Bonjour), which uses IPv6 on your local home network via address ff02::fb UDP port 5353. Here's how you can configure it so IPv6 transmissions are not dropped when Anyconnect is connected.

  1. Make sure that your VPN is set up for split horizon, so that non-relevant VPN traffic goes through your home's network (i.e. youtube.com). If it is not you will need to contact your company's Cisco engineer and convince him to enable it.
  2. Make sure that your home network does not overlap with the relevant IP addresses that go through the VPN. If it does, change your home's DHCP IP address range to something else.
  3. Make sure that you can enable "Allow local (LAN) access when using VPN (if configured)" (see first exhibit below) in the Anyconnect client. If this is forcefully disabled, you will need to contact your company's Cisco engineer and convince him to enable it.
  4. If the VPN profile doesn't have a VPN IPv6 pool, ask your company's Cisco engineer enable "Client Bypass Protocol" in the Anyconnect Group Policy settings (see second exhibit below), which will prevent all IPv6 traffic from your home system from being dropped.

You may have to buy your Cisco engineer a good bottle of scotch or bourbon in order to get this accomplished.

Enable LAN access from Anyconnect setting Enable Client Bypass Protocol from FDM

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .