3

I've got an early 2011 13" MBP with a 120GB SSD, formerly part of a DIY Fusion Drive, that I'm trying to install Yosemite on. Every time I try to install from my bootable drive, it hangs at the exact same point: ETA 11 minutes, last log entry "PackageKit: Extracting file:///System/Installation/Packages/BaseSystemResources.pkg (destination=/Volumes/SSD [that's my drive name]/.OSInstallSandboxPath/Root, uid=0)". That's happened even after I erased the disk, and also after I reformatted the drive. I left Internet Recovery to run a download/install overnight, but I woke up to a gray screen that I couldn't escape from. I tried remaking the bootable drive, but still no change. My latest attempt featured an install initiated from the HDD (that's now plugged in where the optical drive used to go), and that hung for literally two hours. What do I have yet to try, or how can I find out if there's a legitimate hardware problem? (A recent Verify Disk claims the SSD's okay.)

  • Physically installed where the HDD used to live, and the HDD is now in a caddy in the optical drive area. – user24601 Dec 3 '14 at 17:33
  • Early 2011 13" MacBook Pro. – user24601 Dec 3 '14 at 17:35
  • I already have it on a USB drive. That's what I've been working from this whole time (except for one attempt at Internet Recovery that ended in a gray screen). – user24601 Dec 3 '14 at 17:39
  • Update the original question with the info you've provided. Please give more detail about your setup. When you try the install, is the HDD plugged in? You can try and install an older version of OS X, if you have one, and then try and upgrade through the app store. – Flying Trashcan Dec 3 '14 at 17:48
1

Install the OS on to each of the components of the "DIY Fusion Drive" if the system can install and boot from each, you have ruled out a hardware problem with either of the components.

  • The HDD works relatively fine. This problem is just on the SSD. – user24601 Dec 3 '14 at 17:55
  • @user24601 So you can't install onto the SSD itself alone? – bmike Dec 3 '14 at 17:55
  • I can tell you, after having left an install attempt to run for the past 3 hours while I had a math midterm to take, that it's installing. Just very slowly. The ETA's dropped from 11 minutes to 8 minutes, and the log says a new process started almost exactly 3 hours after the process that usually hangs started (but that one's now been running for 1.5 hours with no update in the log). – user24601 Dec 3 '14 at 21:23
0

I would contact the vendor about the problem. It sounds like you have a bad block in the SSD that the SSD controller doesn't recognize.

I read a thread (somewhere...forgot where) where some guys SSD would block at the exact same point every time he tried to do a clone on it. He tried reformatting it and the same problem occurred. He ran Scannerz on it and found a bad block there. The problem was, the SSD controller wouldn't recognize it as a bad block, which is basically a bug in the controller. The guy ended up sending it back.

Possibly the vendor may have some special initialization routines that may clear the problem up.

0

The 2011 MacBook Pro models has/had some issues with SATA 3.0 6GB drives (which the SSD is most likely) in the 2nd (optical) bay. Read the OWC blog entry about this problem.

  • I put my SSD in the first bay. – user24601 Dec 22 '14 at 15:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .