10

Ever since the upgrade to Yosemite, the softwareupdated process always consumes around 100% CPU.

I noticed this the other day when I closed my laptop at the end of the day and the area above the left side of the keyboard was very warm. Looking at Activity Monitor, the softwareupdated process was running at full blast. That also explains the horrible battery life that I have had since upgrading.

I waited to upgrade to Yosemite until after the first xx.xx.1 point release and ever since then the softwareupdated runs constantly, no matter how many times that I kill it.

Is there a solution for this?

MacBook Pro, OS X Yosemite (10.10.1)

  • I tried two things which may have fixed the issue for me. 1) signed out and then signed into the app store, which prompted me to accept a new terms-of-service. 2) I manually applied the latest OSX 'combo update' from apple's yosemite downloads page. After that, the app store and softwareupdated appear to behave. – NobodyMan Jul 1 '15 at 19:33
4

Disconnect from the network and reboot the Mac.

Then see if the process can clean itself up. Assuming it is under control, open system preferences and turn off all automatic checks under the app store pane.

At that point you can reconnect to the internet and see if things are solid before opening the App Store app again.

  • I did all the work in Cleaning up the Question and getting it off Hold :) but I'll give you a + anyway. – Ruskes Dec 3 '14 at 17:50
  • Wow, this did the trick. I – Mark McCoy Dec 4 '14 at 20:51
  • @MarkMcCoy Cheers - the code does a good job repairing itself if you can get it to a safe place to commit to a plan of action. ;-) – bmike Dec 4 '14 at 20:52
  • 1
    Sorry, I didn't mean to post that. I still have the issue with 100% CPU usage. I had forgotten that I had tried disabling the softwareupdated deamon in launchctl so it wasn't running after I rebooted. Once I enabled it again it immediately jumped back to 100%. – Mark McCoy Dec 5 '14 at 21:47
2

Had the same problem after upgrading to Yosemite and then updating. A reboot fixed the (not responding), but it is still a memory hog at almost 500 MB, the biggest process ! This solved it for me :

  1. Go to App Store in Preferences and disable "Automatically check for updates".
  2. In Activity Monitor, kill softwareupdated.
  3. IMPORTANT: Go to App Store in Preferences weekly to check for updates manually.

Hopefully Apple will reduce the size of this daemon in the next update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .