Is there a way to disable inertia scrolling (scrolling speeds up the faster you scroll the mouse wheel) for Yosemite for only the mouse? I understand the reason for inertia scrolling for the trackpad, but makes no sense on the mouse.

I've tried various fixes in regards to this issue:

  1. Downloading Scroll Reverser based on this thread.

  2. Tried this thread's fixes.

But none of them disable the inertia scrolling for mouse. I would still like the default Windows mouse-scrolling behavior where one scroll is the same distance no matter how fast you spin the scroll wheel.

EDIT: Apparently you can disable inertia scrolling by enabling/disabling it in Mouse Options under Accessibility, but mine does not have the dropdown like other people seem to have:

enter image description here

This is the thread in question about mouse option inertia scrolling.

  • Are you asking about scroll inertia (scrolling speeds up the faster you scroll the mouse wheel) or natural scrolling (the direction the page moves when you scroll a given direction with the mouse wheel)? Your question seems to go back and forth and they are two separate things.
    – tubedogg
    Commented Dec 3, 2014 at 5:48
  • I meant about scroll inertia - thanks for clarifying. I'll edit. Commented Dec 3, 2014 at 5:54
  • 1
    I'm not sure you actually mean scroll inertia - which is like the iPhone does, keeps going after you stopped 'pushing' - but sounds more like scroll acceleration to me. Only thing I've seen that can switch on/off acceleration is SteerMouse [about 20 bucks] though presumably other mouse-modders can do it too.
    – Tetsujin
    Commented Dec 3, 2014 at 7:21
  • I'm actually a little confused too. There are so many terminology for the Mac mouse behaviors. Natural scrolling.. Inertia.. Acceleration. What I mean is what I describe, though - scrolling speeds up the faster you scroll the mouse wheel. I don't want it to speed up or slow down - I want it one speed. Commented Dec 3, 2014 at 7:32
  • That's 'just' scrolling - a set number of lines per 'click'. Accelerated is when it does one line at slow scroll, but 10 at fast spin of the wheel. Inertia is that it carries on after you stopped scrolling, like pushing a list on an iPhone. 'Natural' is the direction it scrolls compared to your mouse-wheel. It's supposed to feel more like a phone.
    – Tetsujin
    Commented Dec 17, 2014 at 8:28

6 Answers 6


In Terminal, run the following command to disable mouse scaling.

defaults write -g com.apple.mouse.scaling -1

Similarly, the following disables scroll wheel scaling.

defaults write -g com.apple.scrollwheel.scaling -1
  • I'll try this, but let's first make sure that this setting exists and have a way to revert to previous behavior if needed. On my system defaults write .GlobalPreferences com.apple.scrollwheel.scaling returns 0.3125. Commented Feb 12, 2015 at 9:52
  • 1
    This setting appears to only reflect the "mouse scroll speed" settings, but not have the desired effect, even after logging out/in. Changing it in system preferences then reading the value shows immediate change in the numeric value. Commented Feb 12, 2015 at 10:00
  • 2
    Neither of these seems to stop the inertia effect on the scrollwheel for me :( Commented Jul 31, 2015 at 14:24
  • 1
    defaults read .GlobalPreferences com.apple.scrollwheel.scaling returns 0.125 and defaults read .GlobalPreferences com.apple.mouse.scaling returns 1.5 for me on OS X 10.11.5 (El Capitan). Check your own values so you can undo these changes if you don't like the effect!
    – Dolph
    Commented Jun 13, 2016 at 13:29
  • 1
    Setting the com.apple.scrollwheel.scaling value to -1 seemed to help a little bit, but it's even better for me when set to 0: defaults write .GlobalPreferences com.apple.scrollwheel.scaling 0 Commented Sep 13, 2016 at 11:26

Take a look at USB Overdrive. With it help I've finally removed scroll acceleration and setup custom buttons on my Logitech m570.

  • USB Overdrive is great... until it isn't. I used it for months, but my mouse would occasionally get into a strange state where middle-clicking did nothing, and the pointer would not update based on what it was hovering over. Only a reboot would fix the problem. Commented Jun 28, 2016 at 2:39
  • My mouse wheel used to do nothing for the first 5 clicks (I guess technically that's "acceleration" from zero to nonzero) and now it scrolls on the first click! Commented Dec 11, 2016 at 16:00
  • 1
    @CoreDumpError Christ, that's what's been causing that? I found out it reproduces if you scroll while the mousewheel is depressed. Unplug and replug of external mouse fixes it. Uninstalled USB overdrive now, and now I can also highlight while scrolling the page as well. What a headache. Commented Jan 19, 2017 at 16:14
  • You may want to report reproducible bugs in USB Overdrive Commented Feb 10, 2017 at 16:54
  • Note that this is a 20 bucks shareware program. Its free trial is unlimited but comes with reminders to register when you start up. Commented Apr 13, 2017 at 7:49

This has been a problem and an aggravation for me since Mavericks. I'd like a linear input for the mouse wheel, but there isn't any option for this in Mavericks or Yosemite, and I never found a hack or a terminal command that worked.

I posted this on the Apple forums a while ago and still, no fix is available:


Basically, I want one "nudge" of the mouse wheel to scroll down 4 lines. Currently, and unavoidably, one slow "nudge" moves the mouse wheel about .5 a line. If I scroll down faster, it speeds up, but the end result is that to scroll to an exact position on a large page, I will always scroll past it and have to go back up. It's supremely aggravating and there are no known fixes for it.

  • 1
    As my comment above SteerMouse can do this
    – Tetsujin
    Commented Dec 16, 2014 at 18:17
  • Is it possible for SteerMouse to only change the scrolling behavior [and not my mouse speed/acceleration/etc]? I use the Logitech Gaming Mouse utility [which unfortunately does not have a control for the scrolling behavior], but handles my mouse speed and acceleration needs. Commented Dec 17, 2014 at 5:00
  • @theGreenCabbage SteerMouse is an either/or, either 'number of lines per click' or 'accelerated scrolling'. It can't do both, unfortunately [btw, if you need someone specifically to be notified of a comment, you need to add @ then start typing the name, then click the one you need. Otherwise they may never see it if it was not their initial post. I found this one by accident]
    – Tetsujin
    Commented Dec 17, 2014 at 8:25
  • @Tetsujin Thanks for the reply. What I primarily meant is, can I just enable the Scrolling behaviors and not the other behaviors? I don't want SteerMouse to manage my mouse acceleration and buttons for me. Commented Dec 17, 2014 at 8:27
  • You can leave buttons at default & just set scroll to the desired number of lines rather than accelerated. Though it will conflict, I would guess, with the Logitech control panel, I doubt you could use both at once. Having said that, I've always used it instead of the Logitech for my MX518, 8-button mouse, as it does what I want it to do - & did so long before Logitech could be bothered making a Mac CP ;)
    – Tetsujin
    Commented Dec 17, 2014 at 8:32

Thanks to Tetsujin, I can confirm that SteerMouse does allow linear scrolls. And it allows setting the acceleration and sensitivity of the mouse movement separately too.

To do this:

  1. Open Steermouse
  2. Go to the Wheel tab
  3. Pick Roll Up, then change Mode to "Linear".
  4. Repeat for Roll Down.

If you don't want your cursor speed to change, disable settings in the Cursor tab.

So there is a solution if you're happy paying someone $20 to fix Apple's bugs.

  • Not sure why this is downvoted so badly. It's the only answer on this page that actually works. Commented Feb 6, 2017 at 16:48

I resolve it with this app https://smooze.co. Check [https://discussions.apple.com/thread/5506804] for details.

  • Welcome to Ask Different. Are you the developer of this application? What is that you like about this app that makes it stand out?
    – fsb
    Commented Aug 6, 2021 at 20:55

THIS WORKS! Go to System Preferences > Mouse > Scroll direction: natural (UNCHECK)

  • 4
    I don't think you have any idea what this question is trying to ask Commented May 30, 2016 at 16:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .