Well, the past few days have been a near disaster. This whole problem started when I was using Chrome and I suddenly couldn't access pages. I checked Safari, and it wasn't working either. Since I was getting the "Oh snap!" page from Chrome, I X'd it out and tried to reopen it. Chrome's dock icon would just bounce once (usually it bounces until it opens) without opening. I tried to restart the computer, but the "Restart" and "Shut Down" buttons on the Apple Menu weren't working, so I held down the power button and did a force shutdown. When I tried to turn the MacBook back on, I was stuck in the grey screen forever. I have tried everything on the Apple troubleshooting pages. I tried Safe Mode and I was still stuck on the grey screen. I tried the Safe Mode showing progress, and for some reason I could get back in, but then the cycle began anew with Chrome not working.

I tried the PRAM reset or whatever it's called.

I finally tried to do a Mac OS X from the recovery. Sometimes it won't let me start the reinstall and other times it gets to like 6 minutes remaining and then it will suddenly stop.

Edit: I forgot to mention that I did all the verify disk and permissions and repairs in the Disk Utility in the recovery. I also ran the Apple Hardware Test, and it said nothing was wrong. At times when the computer was able to boot but having troubles I was getting an "unapproved caller" message.

  • 1
    and you do not have USB boot disk ? Restart in Safe mode and remove Chrome for now.
    – Ruskes
    Dec 3, 2014 at 4:33

3 Answers 3


In case anyone is interested, I took the Mac to the Apple Store and the issue was the Mac hard drive cable. They replaced it and it works fine now.


Would help to know the specifics of your Mac. Operating system, Memory etc. Anyway this might be worth a stab: Open up your Mac and check if one of your memory sticks has gone bad (that happens-especially on third party memory). Remove all memory stick except one (one that your computer came with=original Apple memory)-restart...repeat this until you checked all of them. Make sure you disconnect ALL peripherals (printer, external hard-drives etc) before doing this.

If you are able to do a normal boot successfully, put them back in (one at a time) until the problem comes back-meaning the last memory stick was the problem.

Good luck!


This is probably caused by contents of /var/folders/ directory.

Sometimes the upgrade process fails to complete a specific task that is meant to remove cached files from that location. There is a Launch Daemon at /System/Library/LaunchDaemons/com.apple.bsd.dirhelper.plist that is meant to remove the files from the /var/folders location every 3 days, but it sometimes may fail.

Removing the contents of this folder should not affect the system as they are only cached files. This will only need to be done once, then a restart of the system and the Unapproved Caller error should go away.

The most convenient way to do this is:

  1. Load the machine in single user mode: http://support.apple.com/en-us/HT201573
  2. Execute the following command in the terminal (be exteremely careful):

    mkdir /Users/backup cp -r /var/folders/* /Users/backup/ rm -rf /var/folders/*

  3. Reboot the machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .