I am on a Windows corporate network. Since I've upgraded my MacBook Pro (2014) to Yosemite from Mavericks, I am unable to find local machines on our network via DNS.

  • I can get onto my corporate network.
  • I can connect to any machine, webpage, server throughout the world via the DNS name. ( I can connect to Google, Yahoo, etc. with no problems)
  • I can find local systems via the IP address.

What I cannot do is find our local systems via DNS names. For example, I can ping but I cannot ping flubert.prod.local even though that machine's IP address is

This is an issue for many of us Macheads. Many haven't upgraded from Mavericks to Yosemite because of this issue.


This is very common problem in split-horizon DNS and heterogenous but Windows-dominated company networks. A lot of Windows sysadmins are used to the .local TLD as a valid private TLD name since at least a decade though it's not RFC-compliant anymore.

When your local area network has been configured with a domain name ending in .local, then all LAN hostname resolutions queried by a Mac will be passed to mDNS first - bypassing unicast DNS!

So hostname resolutions for .local often fail in Mac OS X applications (Safari, Chrome etc and often ping).

In contrary dig and nslookup are unicast DNS utilities, so they will both bypass the system hostname resolution order (files->mDNS->DNS) and query unicast DNS directly.

Some workarounds exist (your mileage will vary):

  • flush DNS cache frequently
  • add prod.local as search domain (to add local additionally is sometimes advised as well)

enter image description here

IMHO the only proper and RFC-compliant way to fix this is changing the local domain names to use a TLD other than .local in your Windows corporate network.

|improve this answer|||||
  • That did it. Amazingly, if I am on the public network, and then use Cisco Anyconnect to connect to my corporate network, I could use DNS for the local machines. In fact, this is what I had to do when I worked with my Mac for the last two weeks. It caused all sorts of problems because Jabber/Messages and my Voip phone via X-Lite caused problems if I had the VPN running. This makes my life so much easier! – David W. Dec 2 '14 at 22:04

I don't have that issue.

Did you try flushing the DNS cache?

Open a terminal and run this code:

sudo discoveryutil udnsflushcaches

Is your DNS server listed in you network preferences under Advanced > DNS ? If not, add the ip address of your DNS server there.

|improve this answer|||||
  • Yes, I've tried flushing the caches. The DNS servers listed match the ones on my Windows machine when I run ipconfig /all. I was told it had something to do with Bonjour. – David W. Dec 2 '14 at 20:51
  • Ironically, I'm also running a new Windows 7 PC via Parallels on my Mac and sharing my network connection. That PC, even though it isn't on the corporate domain can find the local machines that my Mac cannot. – David W. Dec 2 '14 at 20:58
  • According to this page, Bonjour was replaced in Yosemite. How about: sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.discoveryd.plist and sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.discoveryd.plist – suit4 Dec 2 '14 at 21:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .