4

I've run in Japanese input mode for 6 years now. I generally had no issues. Now with OS X 10.10 (Yosemite) I can no longer type a backslash. This means in order to use the Terminal I have to completely get out of Japanese input and switch it US input where as before Yosemite if I was in Romanji mode things just worked.

How can I either (a) get it to work like it did before or (b) how do I type a backslash while in Japanese Input mode?

Note: Backslash is used in the Terminal and when programming very often. I can't imagine there isn't some way to fix this otherwise Japanese programmers would be up in arms.

7

Turns out there's a setting in Keyboard Settings. Change "¥" key generates to \ (Backslash)

No idea why Yosemite changed that setting from whatever it used to be or if it didn't exist before why they felt the need to change the behavior.

keyboard control panel

Google's Japanese IME has a similar option

enter image description here

2

I found an answer here and again here

If you hold down the "alt option" key on your MacBook keyboard and then hit the ¥ key, it will type a backslash.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .