3

I recently upgraded to Yosemite (10.10.1). Today I tried to unzip a .zip file for the first time since upgrading.

I already had 4 or so unzipping apps that worked just fine on my previous OS X, so I just double-clicked on the .zip, and Yosemite tried to open the .zip with the default unzip app.

Unfortunately, I then discovered that the default unzip app and all of my other ones were not compatible with 10.10.

I checked online and found that according to Apple, in 10.10, to unzip a .zip, you just double-click on the file and Yosemite would unzip it for you.

However, whenever I double-clicked on the .zip, Yosemite would only try to open it with the incompatible default unzip app.

So I deleted all my unzip apps and rebooted.

When I then checked my .zip files, I noticed they all were defaulting to open with TextEdit. When I double-clicked one .zip file, I got this message:

enter image description here

When I double-clicked another .zip file, I got this message:

enter image description here

So the question is does anyone know how to get Yosemite to open a .zip given this situation?

  • 1
    Right-click on one, choose Get Info and change the application listed under "Open With", then click the Change All button. – tubedogg Dec 1 '14 at 22:59
  • I have this same problem! I actually compressed by right clicking on a file, then attempted to open the .zip just created, and yosemite failed to do so. When I clicked, "search app store" it told me that "You can’t open the application “App Store.app” because PowerPC applications are no longer supported." What's up with that? – user150630 Oct 5 '15 at 21:51
  • Select one of your .zip archive, type ⌘I, and include a screen capture within your question. – dan Oct 5 '15 at 22:19
  • What happens if you run unzip archive.zip in the Terminal? – oarfish Jul 23 '16 at 8:01
2

I just had the same problem - usually the double click works but for some reason it didn't work on a zipped mp4 video.

What worked was to right-click and choose 'open with' > 'archive utility'.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .