I have a jailbroken iPhone 4 running on iOS 7.1.1. I checked Cydia and updated a few tweaks and since that update, my tweak called "f.lux" wasn't working so I deleted it. After deleting it, I would swipe to unlock my home screen but my phone would just shut off and restart. Restoring it in iTunes didn't work and errors would always pop up. I tried using TinyUmbrella and it didn't work. I also tried downloading an ipsw file but that doesn't seem to work either. Do I just need to buy a new phone or is there a way of fixing it?

2 Answers 2


It’s not possible to do that without iTunes.

If you have a PC or Mac with iTunes installed, you can bring the device in DFU mode by performing the following steps:

  • Connect the iPhone to your computer
  • Press and hold the Home button and the Sleep button at the same time
  • After 10 seconds, release the Sleep button
  • Continue holding the Home button until this iTunes message shows up: "iTunes has detected an iPhone in recovery mode. You must restore this iPhone before it can be used with iTunes"

enter image description here

You can then restore it to the latest iOS version. Please be aware that this will erase all the data on your device and will restore it to the latest iOS version (iOS 8.1.1 as of Dec 1st, 2014).

Please note: In DFU mode, the iPhone’s screen will remain black until you invoke the firmware restore. If it shows a "Connect to iTunes" screen, you are not in DFU mode but in recovery mode.

  • i already tried restoring my phone while in DFU mode and it still didn't work. Should i try restoring it on another laptop?
    – user103010
    Dec 1, 2014 at 21:18
  • If you used TinyUmbrella before, it may have altered your /etc/hosts file. This can be the reason for the iTunes restore errors. Could you check your hosts file if it contains gs.apple.com entries and if so, delete these rows?
    – aaronk6
    Dec 1, 2014 at 22:13
  • where do i check for hosts files?
    – user103010
    Dec 1, 2014 at 23:41
  • Depends wether you are on OS X or Windows. On OS X, you can enter sudo nano /etc/hosts in your terminal to modify it. In Windows, it’s located at C:\Windows\System32\drivers\etc. To modify it, you’ll need to fire up Notepad as Administrator.
    – aaronk6
    Dec 2, 2014 at 8:02
  • Hey, did this work?
    – aaronk6
    Jan 24, 2015 at 18:39

You can try the following steps:

Step 1: Disconnect the data cable and turn off your iPhone.

Step 2: Press the "Home" button and connect your iPhone to the computer with data cable, and then release the "Home" button.

Step 3: Now you have enter into recovery mode successfully.

Step 4: It is very easy for you to exit recovery mode. Please press both the "Home". button and "Power" button at the same time until the LOGO "white apple" appeared on the screen.

You must log in to answer this question.