0

I've got an Early 2008 Mac Pro (MacPro3,1) that is fairly healthy from what I can tell. It has survived OSX upgrades from the original 10.5 to 10.9.x (haven't pulled the trigger on Yosemite yet) and was always happy on its wired ethernet connection for years until probably a little over a year ago when I'd find from time to time that it would disappear from my home network. I am running it straight into a FiOS Actiontec router, but not sure that it is at fault since I've replaced those over time and the problem still exists.

What I see is that my Mac at some point just loses its ability to talk over interface en0. The router still registers it as connected (i.e. port light is on), but network stack on OSX thinks it is down. I can restore connectivity by doing sudo ifconfig en0 down and sudo ifconfig en0 up with a roughly 1-2 second pause in between. I don't see anything in the system log to indicate a failure other than the various applications which start complaining that they've lost network connectivity. The closest thing I've seen is a message about failure to REBIND, but it follows events for DHCP which normally occur fine. It has been happening for a while, but I want to say that it has been happening since 10.8.x.

It isn't like the network isn't regularly used as the Mac acts as my home's iTunes server and is left on all the time. As well, I don't have power saving features enabled which would suggest dropping the network.

Has anyone else seen this? It is quite frustrating those random times I want to use the Mac either locally or remotely and the network connection is dropped. I haven't seen anything that would indicate a hardware failure so I'm more suspicious of OSX.


I have found a situation where the problem occurs more often. When the Ethernet port is in heavy use (copying large files to the server), it seems to happen more often. When there is no such use, the machine can be OK for weeks. But when I need to copy large files across, the ethernet port can die several times a day.

I've even built a script to disable/enable the port. Most applications don't even notice that the port was down, so everything works again.

Because this happens much more likely under heavy load, could it be related to heat? My machine is full of stuff inside, but the dust has been cleaned away regularly.

  • Check your console logs, if the interface goes down there should be some logs referencing en0. – Alan Shutko Dec 1 '14 at 19:49
  • Have you tried switching to the other ethernet port? The machine has 2. Have you tried a different ethernet cable? – Thorgrim Dec 9 '14 at 5:31
  • @Thorgrim, I've tried using both ethernet ports (though not simultaneously). – bjb May 8 '15 at 7:45
  • Are you using any other interface on your Mac?↵ Could you include the output of an ifconfig -a?↵ Could you include the output of netstat -I en0?↵ I'm convinced that the DHCP renewal problem is a consequence of your link loss and not the other way around. – dan May 12 '15 at 18:18

You must log in to answer this question.

Browse other questions tagged .