0

I've just installed a new version of Yosemite on a third party SSD (Crucial). When I boot it up it hangs on a gray screen.

Steps that got me here:

  1. Connect SSD to Macbook Pro (with existing HD) using USB2
  2. Install Yosemite onto SSD while connected to MBP
  3. Complete installation (at this point, I'm up and running with a working Yosemite running on the external SSD)
  4. Install SSD into internal port
  5. Boot MBP
  6. Immediately hangs on gray screen

I've read about issues with Trim and Yosemite, but to my knowledge I've never enabled or installed Trim on this SSD.

The Option key and Command-R are both non-responsive during startup.

  • I'm not sure why you're going through these convoluted steps, but it is likely the problem. Install the Crucial SSD into your MBP. Boot into Internet Recovery and format the drive (to remove what you have there now). Then install OS X. Upgrade to Yosemite through the Mac App Store. Then migrate your data over using Migration Assistant. Also, for clarity, please don't use shorthand; take the split second to write "with". – user10355 Dec 1 '14 at 4:15
  • What OS did you have before on that SSD ? – Ruskes Dec 1 '14 at 4:19
  • @cksum - I tried the steps you mentioned before going to these more convoluted ones (should have included in post). Ended up in the same place: none of the option keys worked and stalled on gray screen. I'm wondering whether my computer is having trouble reading the SSD through the internal port, although it reads my original hd fine. – Thain Dec 1 '14 at 4:51
  • @Buscar웃 - this SSD has been used to run 10.8 in the past. – Thain Dec 1 '14 at 4:54
  • Calling on Internet Recovery comes before the drive is read from. You actually don't even need to have one installed to pull up IR as it's loaded to memory. Would be pointless rely on the drive as that means if you're install dies, you couldn't use it to recover your system regardless. What year is your MBP? Does it predate IR? – user10355 Dec 1 '14 at 4:57
1

You are most likely suffering from a bad SATA cable. This is a very common issue with any MBP so far, and often presents itself when someone decides to swap out their drive.

You can check this by plugging in both the SSD and an external boot medium and then booting up with option key pressed. If you can see the external medium after some time but not the SSD, your SATA cable is most likely broken.

This is the thin black cable going to your motherboard from the SATA plug. It's pretty cheap to buy and can be installed really easy. It is screwed down to the chassis so you will have to unscrew it before you can replace it.

Addition to my post: TRIM has nothing to do with this. Neither does Yosemite :) TRIM is a garbage collection technology (or: a ATA command to initiate GC on a specific part). Modern SSD's work fine with or without it. The difference is that TRIM can be used by the operating system to direct some specific garbage collection. This is separate from the SSD controller's own garbage collection scheme. You do not need TRIM, you should not install a "TRIM Enabler" as they work (since Yosemite) by disabling kext signatures and blindly modifying some code and/or a plist for a kernel extension. Some newer enablers use local kext signing as an immediate solution. You will however not have any noticeable performance difference, but you will have a system that's been messed with. The only thing you have to make sure is that you don't have your SSD completely filled 99% of the time as this limits the SSD's ability to maintain itself properly in some cases.

0

I would recommend you reinstall 10.10 on to the USB drive using following process.

First restore your system with the old HD and OS to be able to do this:

Connect to your Mac a properly formatted 8GB (or larger) drive, and rename the drive Untitled.

(The Terminal command used here assumes the drive is named Untitled.)

Also, make sure the Yosemite installer, called Install OS X Yosemite.app, is in its default location in your main Applications folder (/Applications). This means that if you moved it before installing Yosemite, you need to move it back before making your installer disk.

Select the text of this Terminal command and copy it:

sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction

Warning: This step will erase the destination drive or partition, so make sure that it doesn’t contain any valuable data. Paste the copied command into Terminal and press Return.

Type your admin-level account password when prompted, and then press Return.

Wait until you see the text Copy Complete, which could take as long as 20 or 30 minutes, depending on how fast your Mac can copy data to your destination drive.

  • As far as I can tell, the problem isn't with my install of Yosemite. I do have a USB with the installer loaded, but am unable to connect to it on startup with the blank SSD installed. Nothing happens when I hold down the Option key, I just go to a gray screen. This isn't the case when I boot with the original HD installed. – Thain Dec 1 '14 at 15:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .