1

Yosemite 10.10.1 on a 2012 MBA

Samba 4.1.13 on a d-link NAS via the miracle of fun_plug

What works:

  • Saving a file to the share from an app's save dialog
  • Making new directories on the share from Finder
  • deleting files and directories on the share from Finder
  • Moving a file from one directory on the share to another in Finder

What doesn't work, and how:

  • Copying a file from my mac to the samba share in Finder: Finder Error -36 and a 0-byte file
  • Duplicating a file on the share in Finder: Finder Error -36 and a 0-byte file
  • cp $file /Volumes/$share/$file: "could not copy extended attributes to /Volumes/$share/$file: Operation not supported" BUT file is created properly on share.

my smb.conf:

[ global ]
netbios name = stuffbox
server string = DNS-325
workgroup = workgroup
security = user
unix charset = UTF8
encrypt passwords = yes
hide unreadable = yes
null passwords = yes
guest account = nobody
max log size = 10
local master = no
log level = 0
dns proxy = no
ldap ssl = no
use mmap = yes
use spnego = yes
socket options = IPTOS_LOWDELAY TCP_NODELAY SO_RCVBUF=131072 SO_SNDBUF=131072
max xmit = 131072
disable netbios = yes
strict allocate = yes
csc policy = manual
allocation roundup size = 1048576
create mask = 0777
directory mask  = 0777
force create mode = 0777
force directory mode = 0777
use sendfile = yes
deadtime = 10
smb passwd file = /ffp/lib/smbpasswd
disable spoolss = yes
nt acl support = yes
acl map full control = yes
strict allocate = no
load printers = no
admin users = sam
vfs objects = streams_xattr
unix extensions = no

[ Media ]
comment = 
path = /mnt/HD/HD_a2/media
browseable = yes
public = yes
oplocks = no
map archive = no
read list = "nobody"
write list = "nobody","sam","@utmp","@sshd"
invalid users =
valid users = "nobody","sam","@utmp","@sshd"

I've played around with the veto files setting, to no avail. Totally at a loss here.

2

I'm not sure because i knever used the option, but maybe you can try "unix extensions = yes" ( Darwin is BSD )

I also suggest to use as less params as possible, it's easyer to find what went wrong that way. These are mine and it works.

   [sharename]
   comment = My Shared Volume
   browsable = yes
   read only = no
   writable = yes
   path = /home/dimitri
   guest ok = no
   create mask = 0750
   directory mask = 0755
   oplocks = no

keep it simple if you want to avoid a comples headache

  • And thank you for downing me without testing it. Since 2000 i've been using every major distro that has been around. So you might want try my answers before voting against them. :| – DaNooby Feb 12 '15 at 11:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .