2

I've just experienced a couple of days of incredibly slow browsing (using Chrome mostly, but changing browser didn't help) on my home wi-fi. After trying many things like rebooting the router, removing devices from the network, diagnosing with iStumbler, requesting new DHCP leases, setting manual IPs, I eventually rebooted the machine and everything is back to normal.

What could cause this behaviour?

It's a mid 2014 Macbook Pro with Retina. The wi-fi is an ageing Dynalink that only supports 802.11b/g. I have a VPN installed but not active, and many apps:

enter image description here

It had probably been a few weeks or even a month since the last reboot.

Throughout all these problems, a Macbook Air on the same network worked just fine - so it's not a question of some weird network saturation.

  • Was one of your (multiple) network drives eating it up ? – Ruskes Dec 1 '14 at 1:22
  • By "network drive" you mean Google Drive or Dropbox? I don't think so - no significant activity that I recall. – Steve Bennett Dec 1 '14 at 2:54
  • They would not do that in front of you, they might do it in background, but you can check the bandwidth (Internet) with the netstat or ls-la – Ruskes Dec 1 '14 at 3:00
  • Sorry, I meant to use the lsof -i to see who is using your Internet. – Ruskes Dec 1 '14 at 3:04
  • ever experienced this again? found the solution? I'm having the same issue on my 2016 MBP. It just gets slow as hell suddenly until reboot, all other devices are fine with the same network. – yefrem Feb 20 '18 at 18:37
1

That menu bar looks like you're on Mavericks. You should upgrade to Yosemite and see if that helps.

Speaking of which, if you haven't already, you should check how Internet-using apps that aren't web browsers perform, such as seeing how long it takes Dropbox to download a new file.

If all else fails, you should go to a place with a newer router and see if anything improves.

  • Ok, those are possible suggestions to fix the problem - but rebooting already fixed it. So I'm looking for diagnostic suggestions, or possible explanations. – Steve Bennett Nov 30 '14 at 22:33
  • Have you tried running Apple Hardware Test? – user24601 Nov 30 '14 at 22:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .