0

I have been having an issue with Mail.app.

After I create an account, even if i do define the password (whether it be via programmatically doing so using applescript OR manually), after I save my changes and close the "Preferences" frame for Mail in which the password can be changed, the password text box resets to be blank. NONE of the other properties change (the username, email, servers etc all are saved and do not reset to be blank text boxes). Here's a visual of the preferences frame with the blank password box issue:

As you can see, the password box is blank and even if i manually change the password and save changes, when I re-open the same preferences window after closing it, the password box is blank once again.

As you can see, the password box is blank and even if i manually change the password and save changes, when I re-open the same preferences window after closing it, the password box is blank once again.

Here is a screenshot of the "Advanced" settings pane: enter image description here

I have tried: -Deleting the com.apple.mail.plist file in ~/Library/Preferences -Deleting any trace of the account in the keychain -Restarting my computer

None of the above works. Any suggestions?

  • Is your password saved in the key chain ? – Ruskes Nov 30 '14 at 4:12
  • @Buscar웃 No it's not – user3541125 Nov 30 '14 at 13:54
1

It looks like you've manually set up your email account instead of using the wizard... you should be using IMap instead of POP with a Yahoo account.

delete the account and re-add it using the wizard.

  • Could you elaborate what wizard do you recommend ? – Ruskes Nov 30 '14 at 4:47
  • in System Preferences, go to Internet Accounts, click the plus and select Yahoo, then fill in your user name and password. – scoutelder Nov 30 '14 at 4:50
  • @scoutelder using the wizard doesn't change anything (IMAP accounts have the same issue). just tried. – user3541125 Nov 30 '14 at 11:00
  • try creating a new user account, opening email and adding your account. – scoutelder Nov 30 '14 at 18:24
  • @scoutelder something weird happens. mail just stops responding after submitting the account info. – user3541125 Dec 1 '14 at 0:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .