8

I tried normal quit, and it closes and immediately re-opens.
I tried force quit, and it closes and immediately re-opens.
I tried force quit from the Activity Monitor, and it closes and immediately re-opens. I tried to restart; this was not allowed because Chrome was open.
I turned off using the power button, and turned back on. Chrome opened (despite not being in my login list, and despite me specifying NOT to open the windows that were previously open)
I tried to delete Chrome; not allowed because it's open.
I tried to force quit then immediately delete, but it opens so fast I can't do that.
I used the terminal rm -rf method of deleting, and pages of text appeared, all saying essentially this but with different things between 'contents' and 'permission denied'. rm: /Applications/Google Chrome.app/Contents/_CodeSignature/CodeResources: Permission denied

Does anyone have a clue what's going on? I am out of ideas.

  • a black Friday bug :) – Ruskes Nov 30 '14 at 0:12
  • is it opening to a specific web site? Also type about:plugins in the address window and disable all stuff in there and test. – Ruskes Nov 30 '14 at 1:19
  • This sounds like a rap maybe someone can edit it? – Brick Jan 3 '16 at 4:29
8

That other answer isn't good because you should not shut down your computer, and it is very unlikely that malware has anything to do with not being able to shut down an application. Do this

  • Type sudo killall Google\ Chrome on the Terminal.

  • If this does not work, do this:

    pgrep -x "Google Chrome"
    

    You will see a number, then type kill -9 numberhere where numberhere is the number that the pgrep command returned.

And to instatly delete the app, no matter if it is open or not, do:

sudo rm -rf /Applications/Google\ Chrome.app

Then type your password.

The reason you get a permission denied error is because you need root access do to this, just use sudo on the terminal for this.

1

Please try the following:

  1. Open the Terminal application
  2. Type "sudo shutdown -h now" and hit enter.
  3. When prompted, enter your password. You will not see the password as it is typed. Hit enter once more.

This should immediately force your computer to shut down. You may have malware on your machine. I recommend having it scanned.

Cheers, Byron

  • Do you have anything to back up your suggestion of malware being present? Your answer doesn't suggest anything to back up your assertion. – douggro Nov 30 '14 at 0:05
  • I second that bug a + from me. – Ruskes Nov 30 '14 at 0:13
  • @douggro: It is not normal behavior for an application to automatically re-open after performing a force-quit. What do you think may have caused this behavior, if not malware? Anytime abnormal behavior occurs, there is an increased chance that a machine is infected with malware. – Byron Formwalt Nov 30 '14 at 23:28
  • 1
    @ByronFormwalt Don't try to strawman me. ;) I agree that it's not normal behavior. Could be a Chrome bug, could be another process respawning Chrome, could be malware. I just asked you to provide support for your suggestion of malware being the cause, for which you have provided none. – douggro Dec 1 '14 at 0:45
1

OS (El Captain):

Had the same issue and couldn't restart (menu restart), but chrome wasn't the culprit. My problem stemmed from an issue with the Dock process. After issuing:

sudo killall Dock 

It force restarted my Dock process and cleared up my issue. Hope this is helpful.

0

You might try doing part of what Byron suggested, but rather than a shutdown, force a restart. In Terminal, sudo restart -h now followed with your password will force a reboot. When you hear the startup chime, press and hold Command-S to enter single-user mode. Then use rm -rf on the Chrome app, and also delete the ~/Library/ApplicationSavedSate/com.Google.Chrome.savedState directory. Reboot again.

0

Try this, it worked for me and feels less forced on the machine!

  1. Click the Apple on the top left corner
  2. "Log Out" of your account
  3. RESTART or SHUT DOWN (shut down seemed to work better)

Once I rebooted Chrome was not running and I could dump it in the trash. I use Chrome on a daily basis but now I am worried of bringing it back...

-1

I managed to quit chrome by going force quit, and select just chrome.

  • 1
    OP stated “I tried force quit, and it closes and immediately re-opens.” – grg Mar 14 '15 at 18:53

You must log in to answer this question.

protected by Community Dec 17 '16 at 15:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .