I tried to download the "Dictionary Free" app from the App Store four days ago, but it's been stuck in "Waiting" ever since. I've tried everything: rebooting the phone, restoring from an iTunes backup, side-loading the app from iTunes, but nothing has worked.

When I turn Airplane Mode on and then off again, I get an alert popup that says "Unable to download application. It will be available for download when you log in to the iTunes Store on your computer".

I've tried what it recommends, but nothing seems to work.

  • When you did the restore from backup, was the app already in "waiting" mode, or did you have to go to the App Store to initiate the download? Second, what version of iOS are you on? 4.3.3? Jun 14, 2011 at 3:07
  • I am using latest 4.3.3 only. Sometimes app be in Waiting or in Loading mode. After this problem I have downloaded that App from iTunes Macbook and performed restore. I have observed something... while clicking on that particular App on iphone sometimes it shows downloaded for 2 seconds and i have opened that Dictionary app in iphone 2 times.. but as soon as I close the app.. that app start showing in Waiting/Loading again. Jun 14, 2011 at 5:36
  • Appstore looks like too funny.... Just saw my that pending App.. now it has been installed successfully. I was messing around here and there... restore process since 4 days.. and nothing helped me... and now its automatically installed... Strange :-| Jun 14, 2011 at 6:45
  • Related: iOS App stuck in 'Loading…'
    – Stevoisiak
    May 21, 2018 at 2:33

4 Answers 4


The springboard has several mechanisms to prevent this from being a permanent situation, but sometimes it falls down. Normally you can cancel a download cleanly. I generally follow this advice to "help" the springboard finish or abort the download transaction:

However, you could have your springboard stuck and a restore is needed. This is discussed here:

With the information you provided, it's difficult to tell which of the two causes is happening on your phone.


After a week with Apple Customer Support, we resolved the issue by reinstalling iOS with a factory restore, setting up as a new device, then restoring the phone from a backup.

To clarify, a factory restore is not the same as erasing all content and settings. A factory restore can only be done by connecting to iTunes.

Restore your iPhone, iPad, or iPod to factory settings

A factory restore erases the information and settings on your iPhone, iPad, or iPod and installs the latest version of iOS or iPod software.

Get your device ready

  1. Check that you have the latest version of iTunes on your Mac or PC.

  2. If you want to save the information on your iPhone, iPad, or iPod, make a backup.

  3. Go to Settings > [your name] > iCloud, then turn off Find My iPhone. For an unresponsive device or one that won't turn on, learn what to do. If you forgot your passcode, get help.

Restore your device to factory settings

  1. Open iTunes on your Mac or PC.

  2. Connect your iPhone, iPad, or iPod to your computer with the cable that came with your device.

  3. If a message asks for your device passcode or to Trust This Computer, follow the onscreen steps. If you forgot your passcode, get help.

  4. Select your iPhone, iPad, or iPod when it appears in iTunes. For an unresponsive device or one that won't turn on, learn what to do. Or get help if your device doesn't appear in iTunes.

    iTunes device button

  5. In the Summary panel, click Restore [device].

    iTunes Summary restore

  6. Click Restore again to confirm. Then iTunes erases your device and installs the latest iOS or iPod software.

    iTunes confirm factory restore

  7. After your device restores to factory settings, it restarts. Now you can set it up as new.

Extra notes:

  • If you want to preserve Health and Activity data when making an iTunes backup, you will need to encrypt your backup.
  • During the new device setup, make sure to select Set Up Manually when prompted for Quick Start. You should not restore from another iOS 11 device.
  • After setting your phone up as a new device, you may want to make sure you can download apps on your fresh device before restoring from your backup.

I've been fighting with this for several days now, and I think I finally cracked it. Check your iTunes Downloads (iTunes->More->Downloads) in iOS for stuck downloads. I had a music video that appears to have been gumming up the works.

Prior to pausing that download I had tried rebooting, logging out of iTunes and all the other suggestions on lots of other blogs/sites/forums.

(Sorry, I have this answer in a few place, the question has a few duplicates)

  • 1
    As of September 2017, iTunes no longer supports downloading iPhone apps.
    – Stevoisiak
    May 21, 2018 at 13:25
  • This is still useful since a sync from a computer can block iOS and springboard from updating. Finder in Catalina has the same functional underpinning of sync code as iTunes started with.
    – bmike
    Apr 22, 2020 at 17:23

Looks like your problem issue was solved by itself but next time here's one thing you can try: jailbreaking.

At very least you'd be able to ssh into the system and try to see what's wrong and perform a high number of tests if you're willing to go deep enough into the rabbit's hole.

For the record, I've had similar issues while installing apps, except they never lasted for even 1 day.

  • 2
    I'm willing to go out on a limb and say that if this App Store problem bewilders a user, Jailbreaking/SSH/everything else would be even more bewildering. Sep 2, 2011 at 16:59
  • @Jason I didn't though of that angle. While that's kinda what I meant with the whole point, I must admit I didn't notice the user in this case could already be bewildered enough without JB.
    – cregox
    Sep 11, 2011 at 5:10
  • 1
    Jailbreaking on it's own wouldn't fix the issue. Please specify what steps a jailbroken user could take to resolve the problem.
    – Stevoisiak
    May 21, 2018 at 13:27
  • @StevenVascellaro i have no clue how jb works nowadays, that is if even still exists. but back then, we were able to get full access to the system and with such great *nix power comes great need of reading a lot of manuals. you can do anything with root access. my "great idea" here was just pointing a direction, not giving a solution, because, well, i don't know the steps and indeed they would be completely bewildering even for me. in retrospect, it was a terrible idea in more ways than one... but perhaps it gave this question a chance for bmike to find it and give it a good answer! ;P
    – cregox
    May 22, 2018 at 11:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .