1

Lately when I try to use the Notes app on Mac OS X 10.8.5, I get a message saying "Notes can't connect to the account JW IMAP", and asking for my password. If I enter the password, then a minute later the same error comes back.

I'm sure this has to do with the fact that my mail moved to a different server. But where is Notes getting the old information? If I choose the Accounts... menu item in Notes, it takes me to the Mail, Contacts, and Calendars pane in System Preferences, which currently has nothing in it. If I click Add Other Account there, it takes me over to Mail, as if I were going to add a new Mail account. But Mail is already correctly connecting to the new server, I don't want a new account there!

I tried repairing disk permissions and it didn't help.

I'm tempted to nuke the Notes files in ~/Library/Containers/com.apple.Notes and see if it gets reconstructed.

  • If you click Accounts in Notes, it opens the internet Accounts, like your emails, Twitter ect.. If you now click on one of the email accounts (assuming you have multiple) it will show you what is this account connected to. It should show Notes in that list, and it is either checked or not. – Ruskes Nov 29 '14 at 7:32
  • As I said, I have nothing in the accounts list. – JWWalker Nov 29 '14 at 15:54
  • I read that!! So you do not have ANY kind of Internet accounts what so ever on your system? hard to believe. – Ruskes Nov 29 '14 at 17:11
  • I don't have any accounts listed in the System Preferences "Mail, Contacts & Calendars" pane. I have several in Mail.app's account settings. – JWWalker Nov 29 '14 at 17:52
  • If you could log in as different user to test the Notes. If it works without problems restore your User permissions settings in Disk utility. – Ruskes Nov 29 '14 at 19:52
0

Notes accounts are usually associated with email accounts like iCloud, gmail, yahoo etc.

if you have an iCloud/iTunes account, log in to it under System Preferences-->Internet Accounts

Click the checkbox next to notes.

Open Notes, then drag your old notes into the iCloud account on the left.

  • I've never had iCloud turned on, and I'd prefer not to. I had been using notes when notes were part of Mail.app, and when I upgraded to Mountain Lion, the notes went into Notes.app, so I never had to configure Notes. – JWWalker Nov 29 '14 at 15:57
  • Do you have any "Internet Accounts" configured in Sytem Preferences? – scoutelder Nov 29 '14 at 18:04
  • No, the "Mail, Contacts & Calendars" pane in System Preferences is empty. – JWWalker Nov 29 '14 at 18:48
  • do you have an account listed on the top left sidebar, ala "On My Mac"? – scoutelder Nov 30 '14 at 1:43
  • do you mean the sidebar of Notes? There's an account "JW IMAP", which is the one it asks for a password for. – JWWalker Nov 30 '14 at 4:37
0

Well, I seem to have fixed it myself. In ~/Library/Containers, I renamed the folder com.apple.Notes. When I next opened Notes.app, it reconfigured itself, asked for access to some keychain items, and now it can communicate with my IMAP account. Furthermore, the next time I went to Mail, Contacts, & Calendars in System Preferences, the list wasn't empty any more.

  • Does not work for me (macOS Sierra upgraded from Yosemite). – Raffi Feb 10 '17 at 19:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .