It's been worse since Yosemite.

From the same exchange account (office365) I will send and receive emails instantly on my phone, but they will take several minutes through the app.

Loading existing conversations also often takes a long time.

Conversations often get jumbled up and emails that don't belong will be added to a conversation.

And finally accepting event invitations is a little messed up. I click accept and nothing happens. Then a few minutes later the email will dissapear and the event will appear in the calendar.

I am having these issues on both my laptops.

I've tried offlining and enabling the account. Also tried reindexing.

Does anyone know if these are just Yosemite bugs? Or is there somethinng I can do to fix it?


  • Have you looked into the Console? Perhaps there are some error-entries which could explain the slow performance. Post anything related. – J.C. Nov 28 '14 at 22:14

I also had extremely slow mail using Yosemite until I did this:

From the Mail menu, click Preferences > Accounts > Mailbox Behaviors


Store draft messages on the server > leave unchecked


Store sent messages on the server > leave unchecked


Store junk messages on the server > checked Delete junk messages when > Never


Move deleted messages to the Trash mailbox > leave unchecked Store deleted messages on the server > leave unchecked


I have found Mail to be much improved following Johann's recommendations.

What I would like to add is the first time I followed Johann's advice I overlooked that I needed to make these edits individually to each of my four (4) mailbox accounts.

If you have multiple accounts usually the first account is highlighted when you enter Preferences. After making edits to that account, be sure to click on each of your other accounts and verify what is checked or unchecked in all of your other accounts.


under the mailbox menu the last item is "rebuild." Do this for each mailbox. The mail will seem to disappear but when the rebuild is done, how long depending on how many messages are in the mailbox, everything should be back and mail.app should run faster.

  • I failed to mention this works in El Capitan as well as Yosemite. – arthur kaye Sep 1 '16 at 13:06

yep, Yosemite is the biggest release ever. For sure the biggest bug release. Problem is caused by AirDrop which is so agressive that it causes network collisions all over. To shut it down and boost web & email type this in terminal:

sudo ifconfig awdl0 down

  • While often Terminal commands can help users resolve problems, issuing a sudo command without understanding what it is doing or how it will resolve the problem can be a recipe for disaster. Please expand on what the command you posted is doing and how it will help. – tubedogg Dec 1 '14 at 3:25
  • @tubedogg awdl0 is a peer to peer created by iOS/OS X to transfer data between devices. The above terminal command, disables this adhoc network, so you lose AirDrop (an possibly Hand-Off). There's also absolutely no indication that disabling the P2P interface has anything to do with any of the bugs mentioned in the original question. I would personally recommend NOT doing this unless bluewhile can post up some credible sources that back up his claims. Lastly, I'm with you on suggesting random terminal commands without sufficient explanation. – user10355 Dec 1 '14 at 4:23
  • google for the command and you will find dozens of results that claim the same. Yes it shuts down AirDrop (and I mentioned that). For 10.10.1 it worked for me. I don't care if you use the command or no - it helped me and I am happy. I just wanted to share it. – paulgavrikov Dec 6 '14 at 4:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .