6

I'm trying to narrow down the cause of a problem that I'm having with OSX 10.10.1 and wanted to see if anyone on here could help weigh in.

I have a Linux-based Samba server running the latest version of Samba (4.1.13). I use this server as a NAS and connect all of my machines to it. I have never had any significant problems in the past connecting my Macs to this NAS.

However, recently I have started to experience some erratic behavior. This change happened when I upgraded to Yosemite 10.10.1.

This is indicated by, very randomly, a share suddenly appearing empty in the Finder. It will still have its icon, but opening it will display an empty folder. When this happens the console will be flooded with "Reconnecting to share" messages - about 10 per second!

This is erratic - I can sometimes go days without it happening, or sometimes it happens within a few minutes of being connected. There is no specific file or folder that I am accessing which causes it. I can simply mount the share and never touch it and it locks, but I can also rsync the entire contents of the share to a backup drive and it does not lock. This to me rules out the possibility of a badly formed filename or something.

If I try to connect to a second share while the first share is in this state, the connection never completes. The "Connecting to smb://..." dialog remains on-screen indefinitely.

And the worst of all: If I actually try to eject the stuck share, the Mac becomes unusable. Apps beachball permanently. The console app even hangs, so I can't read any messages. If I have a terminal up still, executing any command that does any sort of filesystem operation will hang the terminal. Running a "df" command will hang the terminal. Essentially the entire filesystem layer drops the spinning beachball (lol). The only way out is a hard reboot (control-command-power).

The same behavior also occurs if I forcefully stop the Samba server running on the Linux box. As soon as the connection disappears, the Console will show a message reporting that the share is inaccessible, and at that point, the console freezes and no further messages appear, and all of the other filesystem-related behavior I described happens.

The upshot is it seems that the process that manages the mount to the Samba share is buggy in some way. Has anyone experienced issues like this? Before I submit this as a bug report to Apple, I'd like to make sure it's really an issue with the OS X CIFS/SMB drivers, and not with some obscure edge case scenario. Of course, the fact that this issue does not occur on 10.10.0 or any previous version of OS X is a telltale sign, but I am also not even sure what to report because as I said, the behavior is erratic, unpredictable, random and when it does occur, no logs can be obtained.

Thanks!

  • 1
    Any luck resolving this? I'm having the same problem. Beachball hell. – Copenhagen Jan 15 '15 at 17:37
1

I've had similar problems compared to what you're describing, although it sounds like your problems are worse. It's very common based on what I've read and there's no cure. The issue is that Apple isn't using the Samba software but rather their own version. Here's my experience, FWIW:

  1. SMB volumes were slower for me on Mavericks and older on these machines. Upgrading to 10.10.2 has sped it up and made everything work much better.

  2. The shares are still very slow. One very large share performs much like you're describing at times. But other smaller ones are fairly managable, albeit frustrating.

  3. We use Path Finder to connect to our shares, not Finder. This may be superstition on our part, as I don't know if it is actually doing anything different. But it does seem to give us fewer crashes.

  4. DF in the terminal does not create the issue you have, it just lists like normal.

  5. I have upgraded the RAM, but the hardware is older. One Mac Pro 2008 model has 8GB while another has 16GB. I've seen machines have a slow finder when they don't have enough RAM, but the problem is the software. Unfortunately, upgrading the RAM was the only solution I had to improve performance.

  6. Windows shares may not list as slowly as my Linux NAS, but I have no benchmarks to prove that. (That would make sense if both weren't using Server Message Block.)

If none of this information helps you, may I ask if you've tried a fresh install?

As for me, I'm very interested in compiling Samba from source providing I can find enough support.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .