In Yosemite (present in 10.10.0 and 10.10.1) Finder regularly and repeatedly (not just randomly) freezes when in column view.

I always use column view by default, so it happens often. It seems to happen when you click on certain file types-- I suspect the "preview" in the right-hand-most pane is causing the problem.

  • It seems to be related to certain file types (but I haven't figured out which ones yet)
  • If a specific file type causes a freeze, it always does
  • If a specific file type doesn't cause a freeze, it never does

For example, if I click on a "zip" file, it successfully generates a "preview" in the right-hand-most pane. Always works. PDF and TXT also work fine.

However, if I click on a ".epub" or ".mobi" file, it always beachballs or freezes Finder. There are other file extensions that also cause freezing, most "non-common" ones seem to do it.

Anyone else experiencing this? Workarounds or fixes?

  • 2
    I'd also check for old or outdated quick look helpers - I had a similar problem recently, turned out to be an old zip file helper [though I can't off the top of my head remember which one] 3 potential locations /Library/Quicklook ~/Library/Quicklook & /System/Library/Quicklook – Tetsujin Nov 28 '14 at 17:25
  • Please post your resolution as an answer to the question and accept it. For more information on how Ask Different and the StackExchange Q&A format works please see our FAQ. – Ian C. Nov 28 '14 at 17:27
up vote 3 down vote accepted

I was able to resolve my own issue, after finding Quicklook crashing finder in Mavericks:

Rename/remove the com.apple.quicklook.ui.helper folder in ~/Library/Containers. Logout/in or reboot, and the problem is resolved for me.

  • 1
    The folder ~/Library/Containers doesn't seem to exist on my Yosemite Mac. – Thomas Kjeldsen Jun 2 '15 at 12:10

What worked for me was deleting the folder com.apple.quicklook.ui.helper in ~/Library/Containers/, restarting my computer, running disk utilities, "Verify Disk Permissions", then "Repair Disk Permissions".

  • By the way, I'm running Yosemite and to get to the "~/Library/Containers " folder, you click "go" when in finder (it's on the top bar of your computer) then hold down option/alt. It should appear in the list. – user152504 Oct 15 '15 at 10:38
  • Thank you! Deleting com.apple.quicklook.ui.helper wasn't doing the trick by itself, but Repair Disk Permissions did. – hannebaumsaway Oct 21 '15 at 19:25

The folder ~/Library/Containers doesn't seem to exist on my Yosemite installation, but it does on Mavericks.

This is what I did to make it work:

  • Run Disk Utility
  • Choose the partition where OS X is installed
  • Click Verify Disk, if it fails run Repair Disk
  • Wait
  • Click Verify Disk Permissions
  • Wait
  • Click +Repair Disk Permissions_
  • Reboot

It worked for me on five MacBook Pros running OS X 10.10.3.

  • ~/Library/Containers still exists, but this sounds like another option for fixing the problem, that is easier to perform. Thanks for sharing. (Is there a point to running Verify Disk Permissions before running Repair...? Isn't repair what does the work?) – dlehman Jun 3 '15 at 16:45

Not everyone has this issue. Seems to be a user issue (that is, I did not find this problem on the guest account on my MacBook Air). I did the following to fix the problem: Delete all finder preference files under: (user)/Library/Preferences/... in my case that was com.apple.finder.plist and com.apple.finder.plist.lockfile, but there may be more files that start with com.apple.finder... Delete them all (or move them onto your desktop first if you are scared) Then restart the computer. OSX recreates the preference files when restarting and all works well now.

I had similar problems, but I am running macOS Sierra and so the "Repair Disk Permissions" option is not available anymore in Disk Utility nor on the command line.

What worked for me is running RepairPermissions tool from FireWolf available at RepairPermissions V3 – Now supports repairing permissions on macOS Sierra.

After a reboot everything seems to work fine again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.