1

I have two Pages documents in a local folder. They should be synchronised to Google Drive by my Google Drive client. The documents appear as folders remotely.

I'm getting "Upload error - an unknown issue has occurred".

Now if I open the GDrive folder in my brower, instead of SomeDoc.pages, I see a folder with the same name and a structure like so:

Index.zip
preview-micro.jpg
preview-web.jpg
preview.jpg
Metadata
    Properties.plist
    ...
Data
    (images contained in the doc)

Closed and restarted the client, and deleted the faulty remote files. It didn't help (it actually deleted the local files in an attempt to synchronise).

Surprisingly, nothing to be found: search and search on Google nor on stackexchange.

Any idea?

  • OSX 10.10
  • Pages 5.5.1 (2111)
  • Google Drive 1.18.7821.2489

UPDATE

This is stunning: if you open a terminal and ls -la the directory where your document resides, you'll find out the document is actually not a file but a directory, containing all the items I've listed (Data, Metadata...). Even though Finder presents it as an actual file.

I've updated to Pages 5.5.2 (2120). Making a guess from this post, I re-opened the file and re-saved it. Now in the terminal, it shows as a file, not as a directory.

Then I renamed it to trigger a sync (not sure this step is mandatory). I worked. Renamed it to its original name.

The old files still appear "in error" in the Google Drive client, even after I restarted it (by going to Activity Monitor to finish it as there's no quit button in the current version). Still have to fix that part.

  • 1
    Regarding the "stunning" part, those directories-as-files are called "packages", and in specific cases "bundles", in OS X parlance. When encountering such "files" in Finder, you can right click and "show package contents" to navigate inside the directory. Try it with an app or your iPhoto library. – Lloeki Feb 2 '15 at 19:56
  • Thank you, it's never too late to learn these kind of things. OSX does a good job at hiding them from you. – youri Feb 3 '15 at 14:38
1

I can't be sure but I suspect this may be due to Apple's autosave and versioning system.

So I found and tried this to disable it:

defaults write com.apple.iWork.Keynote ApplePersistence -bool no
defaults write com.apple.iWork.Pages ApplePersistence -bool no
defaults write com.apple.iWork.Numbers ApplePersistence -bool no
defaults write com.apple.TextEdit ApplePersistence -bool no
defaults write com.apple.Preview ApplePersistence -bool no

Then create then edit a new document multiple times, and it syncs fine.

There is metadata (extended attriutes?) or something (hardlinks?) on existing documents though, so they may need to be "saved as" under another name, and the original removed.

Initial results show that I don't have file sync issues anymore but I can't be quite sure if my fix is effective or I'm lucky, or an Apple update put things in order. Whatever, feedback would be helpful.

I opened a topic on Google Drive's support forum but with limited hope.

  • I suspect a Pages update has solved the problem, as the document is now stored as a file rather than as directory as I've discovered! See my updated question. The defaults write hack is not needed. But your answer lead me to the solution so at least I can upvote it. – youri Feb 1 '15 at 17:38
  • Actually, I can also accept it as it was "the most helpful in finding a solution". – youri Feb 1 '15 at 17:40
  • Files that have been affected for me were already in the "new" format (which is actually a ZIP), therefore that's not a format issue. – Lloeki Feb 2 '15 at 17:46
1

Did you try to uncheck the following.

Google Drive (drive.google.com), click Option (the gear icon) and Upload settings.

There, uncheck the option Convert uploaded files to Google Docs format.

  • Yep, it's unchecked, and other documents are ok (for instance, .odt) – youri Nov 28 '14 at 13:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .