3

We just received a brand new Mac Mini, which came with Yosemite pre-installed. Our UPS is set to shut down the computer after running on battery backup for 1 minute. I have tested this with an iMac running Mavericks (10.9.5) and the UPS behaves as expected, but on the Mac Mini running Yosemite the computer does not shut down and just continues to run off the battery.

Updated to add: I tested with the CyberPower 825VA and the Mac Mini running OS 10.10.0. Today I installed OS 10.10.1 update and tested again with the same results. I also tested with a Furman F1500-UPS in place of the CyberPower unit and there has been no change in the behavior.

Updated 11/28/2014--I have verified in Terminal that "haltafter" is on and set to 1. I also tried triggering a shutdown by "haltlevel" 100 (shutdown when battery dips below 100%) and the machine is still not shutting down. I tried booting from an external drive that has OS 10.8.5 on it, but the Mini would not let me do this.

Updated 12/01/2014--I booted the aforementioned iMac from an external Yosemite boot drive and it displays the same behavior as the Mac Mini. No progress on the issue thus far.

Updated 12/08/2014--I have now tested 3 different brands of UPS with 3 different Macs all with the same results. Have gone back & forth with Apple support about this for the last week and they haven't informed me of any progress on this issue yet. I will update when/if this is solved.

Updated 12/15/2014--After reporting this bug to Apple and several back and forth calls with them, this issue has been passed up to the engineering team that deals with Power Management. I was told I might hear something back today if there's a quick fix or workaround, otherwise this issue may not be resolved until 10.10.2 is released.

Updated 01/22/2015--After seeing Eric's reply below, I installed OS X 10.10.2 (14C106a) beta. I only tested with 1 UPS so far, a Furman F1500-UPS, but it is now functioning as expected.

  • so what is your pmset -g result? – Ruskes Nov 26 '14 at 23:27
  • @Buscar웃 pmset -g Active Profiles: UPS Power -1 AC Power -1* Currently in use: standby 1 Sleep On Power Button 1 womp 0 autorestart 0 hibernatefile /var/vm/sleepimage darkwakes 0 gpuswitch 2 networkoversleep 0 disksleep 0 sleep 0 autopoweroffdelay 14400 hibernatemode 0 autopoweroff 1 ttyskeepawake 1 displaysleep 0 standbydelay 10800 – jburik1176 Nov 27 '14 at 0:00
  • I assume you have the settings in UPS set up (Energy Saver) to 1 minute! The pmset indicates to have acknowledged your UPS. – Ruskes Nov 27 '14 at 0:32
  • I see the same behavior on my Mac Mini (2012) with Yosemite and a CyberPower CP1500PFCLCD. Everything looks as it should with pmset assuming that Current Power State=3 means that the Mini is running on the UPS. It just doesn't shutdown. – Bill Tanner Nov 27 '14 at 7:54
  • Apparently that's not what Current Power State means. However, "pmset -g batt" reports the Mini is running on battery while "pmset -g ups" says "halt after" is "on" with the value "1". It just doesn't shutdown. – Bill Tanner Nov 27 '14 at 8:01
2

I had the same problem with my new Eaton 3S 550 UPS. I gave installing 10.10.2 beta a try (build 14C99d) and now it works! So hopefully the functionality should be back for other UPS models as well once 10.10.2 is released.

0

Take a look at the output of pmset -g assertions. This shows things which are asserting "don't sleep, don't shut down" sorts of events. I'm having the same problem, with these outputs:

2014-12-09 20:14:39 -0800 
Assertion status system-wide:
   BackgroundTask                 0
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   PreventSystemSleep             0
   ExternalMedia                  1
   PreventUserIdleSystemSleep     1
   NetworkClientActive            0
Listed by owning process:
   pid 33(powerd): [0x0000085800080242] 00:31:19 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" 
   pid 85(hidd): [0x00000ab00009027b] 00:21:19 UserIsActive named: "com.apple.iohideventsystem.queue.tickle" 
    Timeout will fire in 1774 secs Action=TimeoutActionRelease
   pid 35(com.apple.serve): [0x0000000700010138] 01:06:40 PreventUserIdleSystemSleep named: "com.apple.server.filesharing" 
   pid 35(com.apple.serve): [0x0000000700010132] 01:06:40 PreventUserIdleSystemSleep named: "com.apple.collabd" 
Kernel Assertions: 0x10c=USB,BT-HID,MAGICWAKE
   id=500  level=255 0x4=USB mod=12/9/14, 7:14 PM description=XHC1 owner=AppleUSBXHCI
   id=501  level=255 0x4=USB mod=12/9/14, 7:11 PM description=EHC2 owner=AppleUSBEHCI
   id=504  level=255 0x8=BT-HID mod=12/31/69, 4:00 PM description=com.apple.driver.IOBluetoothHIDDriver owner=BNBTrackpadDevice
   id=505  level=255 0x100=MAGICWAKE mod=12/9/14, 8:00 PM description=en0 owner=en0
   id=506  level=255 0x8=BT-HID mod=12/31/69, 4:00 PM description=com.apple.driver.IOBluetoothHIDDriver owner=AppleBluetoothHIDKeyboard

I've not dug through all the assertion stuff yet, but I've got a strong feeling this is related, at least in my case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .