2

I made a hotspot using a Wi-Fi external receiver connected on my laptop running Windows with a program named Connectify just today.

My PC gets the Internet connection via the Ethernet connection and share it with Connectify. The name of my Wi-Fi network is "connectify".

I have noticed that only my iPad and iPhone are able to connect to it.

My MacBook just says "invalid password" when I know for a fact that the password I configured is correct.

I've never been able to connect to my Wi-Fi network from my Macbook. I have already deleted the Wi-Fi location configuration and made a new one without sucess.

What might explain this MacBook or Wi-Fi failure?

  • What wifi receiver? – Ruskes Nov 25 '14 at 17:38
  • It's just a usb that can send internet to my iphone/ipad and windows laptop. Not macbook. – Daan Van Dam Nov 25 '14 at 18:05
  • sorry, where is the USB connected to? – Ruskes Nov 25 '14 at 18:19
  • To a desktop pc connected via lan. It's sending the lan connection via wifi. – Daan Van Dam Nov 25 '14 at 18:30
  • Does the hotspot have a maximum number of simultaneous client connections? Could the password error be a red herring because of bad error-handling from the receiver/misinterpretation from OS X? Try to find out if there is a max connection limit to your hotspot. Also, try rebooting your Mac. I have received invalid password errors from completely valid DD-WRT access points, and it was resolved by either rebooting my Mac or rebooting the router. Just reboot everything and see if it resolves itself. – rubynorails Nov 15 '15 at 15:23
1

Lets try to reset your Macs settings.

            Go to System Preferences > Network.
            Click the Wi-Fi connection.
            Click the Advanced... button on the bottom right.
            Click the Wi-Fi tab.
            Under Preferred Networks, select your wireless network.
            Click the - (delete) button.
            Turn off your Wi-Fi connection.
            Turn it back on.
            Select and login to your wireless network. This will re-save your connection under Preferred Networks.
            Close your laptop and reopen it to test whether it worked.

Next would be to try connecting manually using your Terminal (located in the Utility Folder.

Copy following in to your Termial:

To find the Network

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

To Connect

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

Replace the SSID and Password with your data.

  • There are no preferred networks also terminal says to me "failed to join network" Error: -3924 invalid PMKlocalhost:~ home$" – Daan Van Dam Nov 25 '14 at 19:12
  • Does the first command list the network ? – Ruskes Nov 25 '14 at 20:01
  • Yes it does show the connectify. – Daan Van Dam Nov 25 '14 at 20:05
  • Sorry, connectify is the SSID (network name) ? – Ruskes Nov 25 '14 at 20:38
  • Yes connectify is the SSID. – Daan Van Dam Nov 25 '14 at 20:43
1

Before try association, can you please try if your device is able to scan your desired SSID properly (RSSI value not less than -60 dBm - -70 dBm).

  1. Click on your apple logo.
  2. Select "About this Mac"
  3. Select System Report
  4. Goto "Network" section and select "Wi-Fi"

in this you will get all the network which your mac is able to scan. Look for your desired SSID and look for "Signal/Noise" field. Signal Strength value i.e. RSSI should not be low than -60 dBm for healthy connection.

Sometimes it is seen; when cable connected with Wi-Fi card is loosen it scans the Wi-Fi network at very low rssi, which in result affect the association.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .