2

I keep getting a pop-up window that states "To view this content you must download Java Runtime Environment". I even got it while using Pages. Now supposedly one cannot get viruses on Macs (really?).How can I solve this issue without having to install any programs?

2

Did you update OS X recently?

I've had this happen a few times -- what's happening is that some applications you installed require a java runtime environment, but the one you previously had installed is not compatible with the new version of OS X.

When these pop-ups appear, they don't necessarily have to be related to your foreground application (like Pages). Chances are, one of these programs was set to run in the background, like an auto-updater, but now when it's trying to launch, there is no longer a Java Runtime Environment for it to use, so your system is prompting you to install one.

So, to prevent this pop-up from appearing, you can either install a JRE, or figure out what software you have installed requires it, and disable or uninstall that software.

There are a few places 3rd-party background applications can be triggered from in Mac OS X:

  • Your Login Items (System Preferences -> Users & Groups -> Login Items)
  • User Launchd agents (~/Library/LaunchAgents/)
  • Launchd agents (/Library/LaunchAgents/)
  • Launchd daemons (/Library/LaunchDaemons/)
  • StartupItems (/Library/StartupItems/)

Examine the files in those locations and see if any of them require Java. As a practical example, I just resolved this problem for myself when I found a facebook video chat autoupdater in my user launchagents folder (com.facebook.videochat.nick.plist). I know this is the culprit because one of the ProgramArguments in the .plist file was FacebookUpdate.jar. I just decided to remove that plist file to resolve the issue, but it would have been more elegant for me to have found and run an uninstaller for the facebook video chat plugin. Depending on what launchd job or startup item is causing your issue, you may want to be more careful.

1

The easiest solution is to update with "Java for OS X 2014-001" at the below link. Fixed the Java pop up issue on all three computers I upgraded to Yosemite.

http://support.apple.com/kb/DL1572?viewlocale=en_US

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .