2

How do I fix my little Apple ecosystem, iPhone (8.1) and Mac (Yosemite), to not associate any email addresses with my identity?

Background: Years ago (may well have been before Mavericks), you could set up Message (on your iPhone), and iMessage (Mac OSX), such that any message sent to you from other Apple users would appear on all your devices, as well as any messages you would send out as well. This was awesome for me, as you could converse on a thread with iMessage on the Mac, and then leave your Mac, having just your iPhone, and continue to follow the conversation.

With the arrival of some minor releases, however, my email addresses started creeping into my settings, my icloud address (which I never use), and the email address associated with my Apple Id. Never understood why. And then, this "mirroring feature" of messages feature started behaving weirdly. That is, some of messages that I would send out would appear at the recipient's iPhone as they always have with just SMS, except for the blue bubble, of course, and then some of the messages would appear as being from my email address. With the latter, that means they would appear as being from a different user than normal (identified as just my email address), so that your recipient would have difficulty following a conversation, and you would have difficulty following responses on just your iPhone, depending on which of the two entities representing you (phone or email) your recipient responds to.

This "less than perfect" situation continues today with Yosemite, in spite of the feature being modernized with a new name (Relay something) and publicized as a new feature.

5

Your email address, which is your Apple ID, is what ties everything together. That has not changed since iMessage was introduced.

You can change where the message is coming "from" by going (on iPhone) to Settings > Messages > Send & Receive > and at the bottom under "Start new conversations from", adjust the checkbox to change what shows up as the "from" to your recipients. Most people would use their phone number here.

You should ensure the same setting is selected on your Mac. Go to Messages menu > Preferences > Accounts > select the account which says "iMessage" in small type below your email address on the left side, then on the right side, click the Settings tab and at the bottom, adjust the "Start new conversations from" setting.

The new feature you are referring to is SMS Forwarding, and is mostly unrelated to the above. It allows you to set your phone to forward messages, received on the phone as SMS, to your Mac as if they were iMessages. Replies made on your Mac are sent back to the original sender as SMS, again through your phone.

  • Keeping in mind I’m only talking about “blue-bubble” contacts, what I’m aiming for is having the conversations on my iphone and my Mac be replicated (equal?). This used to work very well in the early days of iMessage (I’m thinking Mountain Lion, but I don’t recall when exactly). Everything I SMS’d to other contacts (along with their responses) would also appear in iMessage/Messages on my Mac (and likewise for things I entered on my Mac). In other words, the whole conversation was replicated both the phone on the Mac. That’s what I’m trying to restore/recover here. – john hight Nov 29 '14 at 23:45
4

I finally solved this issue. Somewhere along the way either an update on my iPhone or iMac caused any iMessages being sent from my iMac to be from my email address instead of my phone number.

I went onto my iPhone and went to Settings > Messages.

My phone number was there and checked, but none of my Apple ID's/emails were listed. So I pressed the button at the top, it said something like "Use your Apple ID", and then it added my Apple ID's/emails as well.

I then restarted Messages on my iMac and it asked if I wanted to use my phone number. I then went into settings for Messages on my iMac and clicked the dropdown for "Start new conversations from:" and my phone number was now available.

2

On my iPhone I just unchecked the email address and then turned iMessage off then back on and it picked up my cell number versus the dang email address

You must log in to answer this question.

protected by Community Aug 12 '15 at 9:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .