I have a 2012 Mac Mini, and a 2012 MBP Retina both on Yosemite. Airdrop worked very well under Mavericks, and I waited to see if the 10.10.1 update would fix it before posting this. My MBP detects my iPhone 6+, but not my Mac Mini, and my Mac Mini does not detect Anything with Airdrop. My Mac Mini is ethernet, but wireless is on, just not connected. How can I get them to see each other?


2 Answers 2


Old Airdrop and new Airdrop are different apps.

This may or may not help you but I found it while trying a mid-2011 and late-2013 iMacs. The docs say anything older than 2009 iMacs and MBP meet the system requirements for Airdrop, however, they don't mention that anything before 2013 is using a different version of Airdrop altogether and it's almost name-only in similarities.

I don't know how this affects your two 2012 versions, but perhaps this is the case for late-2012 and you can check both computers to see if either are affected by this. You will know if one computer has a message like "If you would like to share with another Mac, ask them to open Airdrop in the finder." This is the old Airdrop version message.

If you see two links with selectable options with who to allow discovery of your machine, and another link that says, "Don't see who you're looking for?" Then this is the message with the new version of Airdrop.

If one of your computers is new version and one is old, you can fix this by clicking the "Don't see who you're looking for?" link on the newer version and select "Connect with older Mac."

Now you should see each other in your finder. If this is not the case, then these instructions will not help you.


AFIK the AirDrop is wireless feature, while it could be made to work with Ethernet card.

Turn on Wi-Fi and Bluetooth on all devices.

In case you might want to do it manually, Enable the Airdrop

Open terminal and paste following:

defaults write com.apple.NetworkBrowser BrowseAllInterfaces 1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .