35

Since upgrading to Yosemite I've been having issue with OS X creating additional desktops on my main monitor for no apparent reason. I usually have 3 different desktops setup on my main monitor and just one on my second monitor. By the end of the day, OS X will usually have created 2-3 extra desktops automatically.

I can't find any setting or shortcut that might be causing this to happen. There also doesn't seem to be any reason for it since it can happen as soon as I boot up my computer.

Is there a way to set a maximum number of desktops so I can prevent this from happening?

Image from related question - Why does Mac Yosemite open dozens and dozens of empty desktops?
enter image description here

  • 6
    fullscreened apps create their own space [messing up any Space-specific key commands too] but they should vanish if the app is quit or windowed. – Tetsujin Nov 21 '14 at 21:01
  • 2
    @tubedogg, yes extra workspaces just show up by the end of the day. I can close the workspaces, but they will just show up again eventually. Tetsujin, I'm not using any apps in full screen so I wouldn't expect the extra spaces to be created – tomoguisuru Nov 26 '14 at 18:02
  • 2
    Have you managed to solve this? – simonthesorcerer Apr 14 '15 at 18:16
  • 4
    It happens to me too; I can reach 26 desktops on the main monitor, if I don't remove them. – kiamlaluno May 12 '15 at 7:17
  • 2
    Try disabling "Displays have separate spaces" in System Prefs > Mission Control. It might be related to connecting and reconnecting (or sleeping) the secondary display. – Elliott Aug 13 '15 at 21:20
4

It has to do with the 'separate space' feature for external displays Apple introduced in OS X 10.10 Yosemite: If the setting "Displays have separate Spaces" in System Preferences -> Mission Control is activated (see https://support.apple.com/kb/PH18809?locale=en_US), every time you hook up a display a new space will be created for that display. After you pull the plug, OS X will not delete that created space, hence accumulating lots of spaces over time.

If you don't activate the option, you're external display will behave like before 10.10: only one menu bar on the main screen etc.

  • Huh. When I plug my external monitor back in, it reuses its old spaces. – SilverWolf May 15 '18 at 14:24
  • I guess then it is fixed by now. – tnull May 16 '18 at 14:57
1

It is not normal behaviour to have multiple (in your case dozens) of extra Spaces being created via Mission Control.

I looked at System Preferences >> Keyboard >> Shortcuts >> Mission Control, but there is no shortcut for creating a new Space. As such, it wouldn't be that you are inadvertently creating Spaces using a shortcut.

Now, when you go full-screen with an application (e.g., Safari), then that window will become its own Space. However, when the window is closed, or restored to its original size, it will return to its original Space.

Considering your situation, I would submit the issue as a bug that Apple needs to address.

1

It does very much sound like you've made the application "full screen". These are given their own desktop space. If you're using a trackpad, use three fingers to scroll up or down (I'm not on my MBP right now) and you'll see them all there.

If they're your full screen apps, make them NOT full screen.

You must log in to answer this question.

protected by Community Jan 19 '15 at 11:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .