6

On Yosemite, I don't use Safari at all. Never.
Every now and then (like once a week or so), Safari automatically opens, without my interaction and it does not even come to forefront, it just remains in the background, and I notice it when I go to the dock to open something else and notice it is there.
It appears to just want to connect to apple home page (no suspicious tabs or anything that I can see).

Anyone has any suggestions?

  • 1
    There are many places that could activate Safari without you specifically asking for it. What does it say in the web address? – Ruskes Nov 20 '14 at 22:30
  • 1
    do you have "guest" accounts enabled? do you have more than one administrator account? What extensions do you have installed in Safari? Anything that looks suspicious? – zerohedge Nov 20 '14 at 22:33
  • THe address bar says apple.com and I don't have other admins or ever used the guest account on my machine. And surprisingly, it must be either coincidence, or have to do with the recent OSX update, it has happened a couple of times since I posted this question. Nothing else looks suspicious. Never installed extensions in Safari (I use chrome and sometimes firefox). – Ali Nov 21 '14 at 11:01
  • 1
    is it set as not the default app for all possible file/mime types? rubicode.com/Software/RCDefaultApp would be the only tool I know to work through that. [btw, it's very old but works fine to Mavericks - I don't have Yosemite yet] – Tetsujin Nov 21 '14 at 21:41
  • Thanks @Tetsujin tried it and nothing is assigned to Safari. – Ali Nov 21 '14 at 22:55
3

I was having the same problem, about twice a day. I installed Little Snitch to see what servers were involved, and I noticed a Dashlane server was one of them. I disabled the Dashlane extension in Safari and it hasn't happened for the last 24 hours.

  • Good approach. But I doubt that it was the "cause". I don't have dashlane extension. It maybe that for some other reason Safari starts and the extension by default, contacts the servers on startup. – Ali Jul 15 '15 at 17:06
  • 1
    I agree, the root cause is probably something different, and Dashlane is probably merely a catalyst in my particular environment. But the problem seems to be gone for me now that I have disabled Dashlane. Sorry it didn't help in your case! – wgmccallum Jul 16 '15 at 23:52
  • I am now having this problem again, so the Dashlane fix did not help. Safari tries to open repeatedly during the day. (I have an Applescript that quits Safari every minutes, so it doesn't stay open.) – wgmccallum Aug 9 '15 at 17:17
  • I'd be tempted to try looking at Little Snitch if you already own it or want to try it out - but don't just look at Dashlane, look for any recent connection & its probable cause. – Tetsujin Sep 29 '15 at 19:51
0

I've been having a similar problem. I will have text selected in some other application, and I will use a keyboard shortcut, and suddenly my Mac has opened Safari, gone to Yahoo, and searched for the text I had selected. This was very annoying and surprising, because Safari is not my default browser. And I don't have Dashline or any other Safari extensions installed. But I finally figured it out. I went to System Preferences : Keyboard, clicked on the Shortcuts tab, then chose "Services" on the left. (I actually got there from the Spotlight preferences, which has a button that took me to keyboard preferences.) There's a long list of services to scroll through. I found one called "Search with Yahoo," and it was checked. (I assume it said "Yahoo" because that was my default search engine in Safari.)

Keyboard Shortcut Preferences Screen

The check box assigned a keyboard shortcut of command-shift-L (which I use all the time in another application, and only when something is selected). So I unchecked it and the problem has gone away.

I don't know if this helps you, but it might be useful to go through the keyboard shortcuts to see what you find.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .