11

I have two monitors, but only one dock, which is somewhat annoying, so my question is, how do I get multiple docks? (One on each screen)

4

There is no way of doing that.

When the Dock is configured to appear at the bottom of your screen, it's available on whichever screen you’re working on. Just move your pointer to the bottom of either display. When the Dock is configured for the left or right position, it appears on the leftmost or rightmost display edge.

Tip: If you don't see your dock because it's set to hidden or there's a full screen app on the display, move your pointer to the location of the Dock. If the Dock still doesn't appear, swipe your pointer towards the Dock again to unhide it.

Source: OS X: Using multiple displays in Mavericks

  • 1
    Oh, but the dock won't appear on the right screen, it stays on the left forever no matter where the cursor is. – Mobilpadde Nov 20 '14 at 17:35
  • Well, I don't know what I did, but it seems to be working now... :D – Mobilpadde Nov 20 '14 at 17:51
3

Set the dock position to bottom and arrange the 2nd monitor to be to the left or right of the 1st monitor. The dock will be present on the monitor with the cursor, or be hidden at the bottom of the screen if auto-hide is selected.

This applies to Yosemite.

  • Oh, but the dock won't appear on the right screen, it stays on the left forever no matter where the cursor is. – Mobilpadde Nov 20 '14 at 17:35
  • Well, I don't know what I did, but it seems to be working now... :D – Mobilpadde Nov 20 '14 at 17:52
1

I had Dock on all monitors, but suddenly it stopped working. I found out that Dock on all monitors only works if Mission Control -> Displays have separate Spaces is checked. I'm using Mojave 10.14.

dock on all monitors dock on multiple monitors

Displays have separate Spaces:

  • CHECKED Dock appears on all monitors, but you can't span a window across multiple monitors.
  • UNCHECKED Dock does not appear on all monitors, but you can span a window across multiple monitors.
0

I had this problem when I had the second monitor positioned slightly higher than the laptop display in Preferences. After changing the position so that the bottom edges were even, the dock now appears on both screens.

0

For some dumb reasoning you have to SELECT the screen before the dock move to the other screen, Click on the Desktop and then point the mouse to the position you set the dock.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .