1

I recently clean installed Yosemite on my 11" Macbook Air and my Google calendar will not sync with Calendar.app. Everything else on my Google account syncs with no problem, but the calendar refuses. I tried with another google account and had the same problem. Turned off 2-factor auth, same problem. Tried with CalDAV, doesn't work.

In Preferences > Internet Accounts > Google Account in Question, the box next to Calendars is unchecked by default. When checking it, I get a progress wheel that spins for a minute or so and then...nothing.

Is there something I'm missing here?

Edit: Y'all need to let this question go. Eight years later, people are still posting non-answers as if I'm still trying to get this to work!

The problem was unsolvable. It was just two apps not playing nice for a couple days and a patch fixed it.

5
  • Have you tried unchecking Calendar from System Preferences > Internet Accounts > your gmail account and waiting 1 minute and then rechecking it? Nov 20, 2014 at 16:29
  • @ProfFrnswrth I edited the question to include that. Thanks for reminding me.
    – Tomulent
    Nov 20, 2014 at 16:35
  • The problem fixed itself, but I have since clean installed Mavericks and I'm experiencing the same problem. I suppose it will fix itself again eventually...
    – Tomulent
    Dec 5, 2014 at 21:01
  • 1
    10,000 views and only one upvote Apr 12, 2016 at 13:35
  • Yeah, that is because people are looking for a solution to the Google/OsX sync problem, and the solution that this thread provides is not effective, maybe because the specs are outdated.
    – Cost
    Jul 1, 2016 at 11:27

6 Answers 6

2

Have you tried changing what to be synced here? This is the Google Calendar Sync select page, it is also available for iPhone.

On these sites you are able to choose, which calendars are being synced. Your choices are:

  • All of your own calendars
  • All the calendars you've subscribed to.
1
  • I'll hop back to 2014 and try that
    – Tomulent
    Aug 27, 2016 at 17:23
2

Have been having the same problem and have just made some progress:

  1. I went to Calendar Preferences -> Accounts tab -> and set Refresh Calendars to Manually. My calendars then immediately appeared (but no events).
  2. I selected View -> Refresh Calendars. Events started appearing.
  3. I've now set it back to refresh automatically and we'll see if the problem is actually solved for good.
0
0

Mine works perfectly after removing/adding.

Have you removed, if you still have it there, the Google account and quit Calendar.app. Then restart Calendar.app, then go Calendar > Accounts and added it back?

1
  • Yes. I've done that multiple times
    – Tomulent
    Nov 20, 2014 at 18:27
0

Same happened for me on a macbook pro with Yosemite, and the problem fixed itself after a couple of hours.

I have multiple gmail accounts configured, and noticed that each account started to fail after I had accepted 'upgrade to the new google calendar app', so I believe this is a side effect of google rolling out a new version of calendar.

0

I got the same problem. For me it worked to delete the Google account in Internet Accounts altogether, then adding it back.

-1

Go to account settings and check individually calendars for them to update.

1
  • Account settings does not show individual accounts. Apr 12, 2016 at 13:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .