I was trying to upgrade Xcode because it didn't let me upload to apps to iTunes Connect.

Now it's stuck in installing state (few hours) and doesn't start:

Xcode is being updated 
Xcode can not be opened while it is being updated.

what do to?


11 Answers 11


There is a small progress bar under the Launchpad icon in the Menu Bar.

Image showing the progress bar

You can also see the current download progress by hovering over the icon.

Wait for it to end.

  • 7
    I couldn't believe how long it took (and was "stuck" at the end for 60% of it) but waiting it out was all it took (wait time: 2.5 hours on 2013 MacBook Air) – Jared Aug 3 '15 at 15:54
  • This will not even begin to load for me on this new computer I was given. – JGallardo Oct 6 '15 at 15:51
  • 1
    How can it possibly take so long. I guess VS also takes a long time, but it is more like an hour vs 2.5 hrs. – tofutim Nov 14 '15 at 1:04
  • 1
    It sounds ridiculous but this really is the solution most of the time. My Xcode on Big Sur was stuck on "11.57GB out of 11.75GB" for almost an hour before it finally just finished on its own. – Saeed Baig Dec 29 '20 at 4:10

In the Updates tab of the Apple App Store, after waiting 1 hour for "2 minutes left," I hit CMD+R to refresh and that seemed to "jump start" it. It finished within 60s after that. Could have been coincidence though (YMMV).

  • I did this and after an hour and a half of getting nowhere being stuck on "2 minutes left", it worked in ~3 minutes. – Jake T. Jun 26 '18 at 16:16
  • Obviously !!! 🤯 – Gomino Jul 16 '19 at 0:14
  • It works!! Stuck for hours, hit CMD+R and it finished in 1 minute :) Very strange.. – trinity420 Jul 28 '19 at 16:37
  • same here, mine was stuck on 99%, then I pressed cmd+R within the updates tab, and it magically finished. – xdavidliu Oct 9 '20 at 3:35
  • My Xcode was stuck overnight (12+ hours) at 99%. Full gigabit internet (so that wasn't a problem). My computer wouldn't even let me restart until it finished. So I started to panic and found this tip. This was the only thing that worked. I pressed "refresh" and xCode finished up almost immediately. – jacurtis Dec 24 '20 at 20:17

Everything is much more simple... open AppStore and click on the "Store" in the top-left menu and choose the following option - "Check for Unfinished Downloads...". Enter your Apple ID and password and you everything will be up and running.

The reason is that XCode does require additional confirmation before download.

Hope that helps.

  • Thanks a lot, I would never have guessed it. It's beyond me how Apple can have a software that needs confirmation that doesn't ask for confirmation. – laurent Sep 4 '18 at 9:51

In launch pad hold the Xcode icon until the X appears and click the X to delete Xcode then go back to the app store and get a fresh copy.

  • 1
    Strangely this worked for me but didn't require me to reinstall. It kicked it out of the installing state and finally finished installing it. Very bizarre but worth a try for others. – aug Jun 5 '19 at 0:06

sudo rm -rf /Applications/Xcode.app should wipe it out, then you can re-install from the App Store. But do make sure it's not actually updating first. It's a multi-gigabyte download so can take a while (yes, even hours, depending on your internet speed.) Opening Launchpad will show a progress bar if it's in the middle of doing something.


I had a similar problem but posting here in case someone found this link through Google like I did.

Xcode was not installing because I was not logged in to my account (it was a new computer).

If you need to uninstall a previous version though, you can run this in the terminal

sudo rm -rf /Applications/Xcode.app

and then close out the App store, open it back up, log in, then try again, you can then see the progress under the launchpad icon.


The Xcode had stuck in installing. I just opened finder, applications folder and tapped on XCode. The installing has finished immediately.

I am not sure if it is coincidence.

Xcode 10.3, Mojave 10.14.6


Sometimes, a simple restart can solve this.

  • 4
    This would be better as a comment – JGallardo Jul 14 '16 at 19:43
  • 2
    It’s an answer and not a comment. It might not be a good answer or even the correct answer, but let’s let the votes sort those out. – bmike Oct 14 '19 at 21:41

Download a fresh copy from Apple's download page


It is now April 2018 and the same problem continues. Mine has been stuck for almost 5 hours.

I have restarted, deleted the downloaded/downloading version of Xcode, and checked for unfinished downloads (there were none).

Deleting it finally allowed me to open Xcode again to continue my work.


For the benefit of anyone else running into this problem - I don't use my MacMini much. In fact I am back on it right now after a break of almost one year. When I tried to startup XCode I got this same message and it would not budge. I uninstalled it and then tried a reinstall only to be told that my OS was "too old". So there you have it - the system goes into a tizzy trying to upgrade XCode and being held back by the OS not being up-to-date. Instead of failing gracefully, it keeps trying over and over again!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .