0

I use to be able to run this ps command from the terminal:

ps -u whoami -o pid,rss,command

But recently the RSS size returned are all 0!

ps -u `whoami` -o pid,rss,command
158      0 /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock
159      0 /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer
160      0 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
165      0 /usr/sbin/pboard

unless I run it with sudo

sudo ps -u `whoami` -o pid,rss,command
158  17556 /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock
159  22488 /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer
160  82176 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
165    840 /usr/sbin/pboard

Does anyone know how to fix this or how to get the original functionality back?

  • What level of OS are you running? The ps -u does not work for me on 10.6.7 - ps -U works so either your OS is different or your path has an alternate ps binary or I'm missing something else obvious. (FYI MD5 (/bin/ps) = 32a504d1010b2e40beebe8c30ff7bf6d ) – bmike Jun 10 '11 at 16:49
1

I have 10.6.7 and your

ps -u `whoami` -o pid,rss,command

producing

  PID    RSS COMMAND
  180    696 /sbin/launchd
  185  19108 /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer
  189     32 /usr/sbin/pboard
  .... etc ....

so, the problem is in your system. So, what return this:

ls -l /bin/ps

should this

-r-sr-xr-x  1 root  wheel  134816 12 okt  2010 /bin/ps

if your ps has other permissions, repair with:

sudo chown root /bin/ps
sudo chgrp wheel /bin/ps
sudo chmod 4555 /bin/ps
-1

This looks on the face of it to be a permissions issue.

I would try and Repair Permissions as per http://support.apple.com/kb/HT1452

  • I suppose if the set-user-ID-on-execution bit on /bin/ps (or whatever ps is in the path first) were gone this makes great sense... $ ls -la /bin/ps -r-sr-xr-x 1 root wheel 134816 May 18 2009 /bin/ps – bmike Jun 10 '11 at 16:52
  • The repair permissions might have worked, how ever I ran sudo chmod 4555 /bin/ps and the issue has been fixed. The permissions were -r-xr-xr-x@ 1 root wheel 132K 18 May 2009 /bin/ps* Now -r-sr-xr-x@ 1 root wheel 132K 18 May 2009 /bin/ps* – Munkymorgy Jun 12 '11 at 10:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .