Recent Items under the Apple menu or in the Dock could be an excellent way to quickly access files that you have been working with recently. Alas, it's functionality is destroyed by obvious document file types not being included in the list. If you open a PDF it's included, if you open a Word file it's not. That makes no sense.

enter image description here You can see in the picture above that even though Office applications have been included in the recent list, the actual documents (.doc[x], .ppt[x], .xls[x]) that were opened have not.

Is there a way to adjust the file type list to go into Recent Items/Documents to a useful set of document types?

  • I'm guessing that applications have to "tell" OS X about the documents they are working with for them to appear there. (That's just a guess though.) You could recreate the functionality you are asking about with a Smart Folder on the desktop, which could be dragged into the dock.
    – tubedogg
    Commented Nov 21, 2014 at 8:28
  • Hi tubedogg, I tried to do what you suggested, i.e. creating a smart folder with a last opened date is within... but to my surprise, even this didn't list any MS Office documents. The respective applications appear as in the Recent Items list but not the actual files. Is this a problem on my system or can anybody reproduce that bug?
    – SeanJ
    Commented Nov 25, 2014 at 9:34
  • I'm not sure what Last Opened Date is...it doesn't appear in Get Info for any of the files I spot-checked, so I tried using it as a Smart Folder criteria and it pulled weird results. Try using Last Modified Date instead.
    – tubedogg
    Commented Nov 25, 2014 at 20:31

4 Answers 4


This problem has been fixed in OS X version 10 / Yosemite or possibly earlier. Now, Office files are listed in the recent file category as they should be (see below).Yosemite Recent Items menu


Another way to try it is to set the recent items list to zero, so it shows nothing, ever. You can do this in Terminal.

In Terminal:

defaults write NSGlobalDomain NSRecentDocumentsLimit 0

Normally that's a 20. just set the default to zero and you shouldn't see anything in recent items.

For an application-specific change (for instance, Safari) use this command:

defaults write com.apple.safari NSRecentDocumentsLimit 0

Replace com.apple.safari with the proper wording for the app you wish to modify, like vlc or flipplayer or whatever.

To reset default values, type:

defaults delete com.apple.app_name NSRecentDocumentsLimit

to remove the application-specific setting, or

defaults write NSGlobalDomain NSRecentDocumentsLimit 20

to set the global value back to 20 (or whatever you want)


Is there a way to adjust the file type list to go into Recent Items/Documents to a useful set of document types?

Not that I know of, but you can increase the number under System Preferences> Recent Items, which might help.

  • Hi, Jack. Thanks for the idea. Alas, it's not a problem of the list being too short. The files I would like to be in the recent items list are excluded even if it was the last file opened.
    – SeanJ
    Commented Nov 25, 2014 at 9:38

The problem I think lies in the mac definition of documents, which doesn't include Microsoft documents. I had the same problem when trying to set up a recent documents smart folder, and when I selected documents as the file kind word documents etc would only appear if opened in a particular way. However, if you set it up to find particular file extensions ie .docx and arrange the files by date opened it works. You can then add a series of file types (.doc, .pptx etc) to get a list of recent. To do this with smart folders you need to press the alt button whilst clicking the add condition to have the necessary options to collate multiple file types.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .