20

I hope some real OSX Nerds read this. Since Yosemite I have the problem taht I can't use the Magic Mouse anymore. It disconnects and reconnects every 5-60 second.

I find this in the console logs:

05.11.14 14:39:22,000 kernel[0]: [AppleMultitouchDevice::willTerminate] entered
05.11.14 14:39:22,000 kernel[0]: [AppleMultitouchDevice::stop] entered
05.11.14 14:39:35,000 kernel[0]: [BNBMouseDevice::init][85.3] init is complete
05.11.14 14:39:35,000 kernel[0]: [BNBMouseDevice::handleStart][85.3] returning 1
05.11.14 14:39:35,000 kernel[0]: [AppleMultitouchHIDEventDriver::start] entered
05.11.14 14:39:35,000 kernel[0]: [AppleMultitouchDevice::start] entered

Can somebody hint me in the right direction, how to solve that problem? Please.

it's so anoying

Best regards Mirco

migrated from stackoverflow.com Nov 20 '14 at 10:53

This question came from our site for professional and enthusiast programmers.

  • Rechargeable batteries? When did you last replace them? When did you last clean the electrical contacts, both on the inside of the mouse, and on the ends of the batteries? Three volts isn't a lot of juice. It only takes a tiny bit of oil or crud to reduce that to a voltage the mouse does not like, and 'Battery Level' is no good at telling you about things like that. – Wayfaring Stranger Jan 16 '15 at 15:42

14 Answers 14

30

Update! - Delete "Bluetooth PAN" from network settings and wifi and bluetooth will instantly work better. Credit: http://ihealthgeek.com/2015/02/yosemite-10-10-2-wifi-and-bluetooth-finally-solved-no-really/ Delete Bluetooth PAN from Network settings to fix yosemite bluetooth/wifi issue

Otherwise, you can try my previous approach that works better, but is still a nuisance.


  1. Turn off bluetooth on macbook
  2. turn off keyboard/mouse
  3. turn on bluetooth on macbook
  4. Hold power-on key on keyboard WHILE
  5. Choose the Bluetooth>Device>Connect from the macbook
  6. Connection should succeed immediately
  7. Release power button on device

This has worked for me repeatedly after trying the PRAM and other no-fix fixes. It's a pain to do, but works everytime for me, and stays connected until I leave the room.

  • Weird, this worked for me. Although I think you forgot step 3.5 - turn back on keyboard/mouse? – powers Nov 18 '14 at 22:06
  • @powers, holding the power on button on the magic keyboard turns on and enters blue-tooth pairing, do you still hold the power key for the mouse? Wondering if step 3.5 is optional for mice only, and if step 4 is still accurate. – Eddie Nov 18 '14 at 22:49
  • There is no power button on a magic mouse (just a switch). Perhaps it goes into pairing mode automatically. I must have misread your comment, I hit the power button on the computer, which turned off the screen for a few seconds, after which my mouse would connect again. Weird. – powers Nov 18 '14 at 22:51
  • 1
    Starting from Eddie’s answer and from what @powers said in the comment, I tried a few more things. This is how my Magic Mouse would finally reconnect: 1. On the MacBook, leave Bluetooth enabled. 2. Enter Sleep mode by pressing and holding the power-on key on the MacBook’s built-in keyboard for a second or so. 3. Turn off the mouse. 4. Wait a few seconds and turn the mouse back on. 5. Wait a few more seconds, then press a key to wake up the MacBook. – Synoli Nov 19 '14 at 10:00
  • 3
    Hey, I can confirm, that deleted the PAN network helped a lot, immediately! Strange but thank you for that tip! Recommended. – tomis Jul 16 '15 at 15:53
5

i know it may sound weird. I tried clearing PRAM and did all other things...But my mouse will not connect to the mac. Then one day i found out it will solve my problem of magic mouse not connecting to mac.:

  • disable blutooth
  • go to finder
  • click on AirDrop on left
  • click on Turn on Blutooth( not from main navigation menu, but this option is visible in finder when you clicked on AirDrop with blutooth off)
  • click on allow me to be discovered by everyone on the bottom
  • try to pair
2

Turning WiFi off worked for me - bluetooth immediately saw the mouse and connected. Note, if you've been trying a bunch of things your mouse may have stopped trying to pair. In that case, turn wifi off and then turn your mouse off and back on. Should sync right up.

  • For me it was the conflict at 2.4GHz with 802.11g WiFi ... switching to 802.11n at 5GHz fixed it. – uzi Jan 28 '15 at 4:42
2

I found a suggestion to add a piece of paper between the 2 batteries, and have this paper push slightly against the mouse cover. Worked for me. Many other suggestions found here: https://discussions.apple.com/thread/2217770?start=90&tstart=0
Also: https://discussions.apple.com/thread/6602914?start=15&tstart=0

  • Sadly, I've resorted to this as well. Apparently, the device needs a better capacitor or structure to lock in the batteries. – bmike Aug 31 '15 at 1:05
1

After changing 2 magic mouses, I found out that the constant disconnection was due to loose battery contact. I slot some paper in between the batteries to limit their movement and the disconnection issue is solved.

0

Reset PRAM

Choose Apple menu > Shut Down.

Locate the following keys on the keyboard: Option, Command (⌘), P, and R. You will need to hold these keys down simultaneously in step 4.

Turn on your Mac.

Immediately press and hold the Option-Command-P-R keys. You must press this key combination before the gray screen appears.

Continue holding the keys down until your Mac restarts, and you hear the startup sound for the second time.

Release the keys.

After resetting your computer’s PRAM, you may need to update your speaker volume, display resolution, and startup disk preferences
  • 1
    THis worked for me for a day or so, and now again yosemite can't initiate or keep a connection with my phone or keyboard. – Eddie Nov 5 '14 at 14:14
  • PRAM Reset does nothing since a coulple of Years (I think its standart resetted since MountainLion every couple of days). So this is the typical Homeopathic Answer in the Mac world. Don't expect anything from that. I tried it and the error did not occur for 5min..... so no change here – Mirco Blitz Nov 5 '14 at 14:39
0

I had the same problem and I think I spotted a possible cause of the problem. My mouse was called "My Name's mouse" with the apostrophe, maybe that was causing the errors.

I have changed the name to avoid using spaces and special characters, now is called just "mymouse" and I don't seem to have the problem anymore.

0

This worked for me https://discussions.apple.com/thread/6621628

  1. Turn Wifi OFF
  2. Turn Bluetooth on macbook off then on
  3. Connect to device in the bluetooth menu
  4. Turn Wifi back on

Apparently turning wifi off wakes the bluetooth up. Hope Apple wakes up soon and looks into this one.

0

The WiFi suggestion from rastriffler let to what fixed it for me -- I have both 802.11g (2.4GHz) and 802.11n (5GHz) networks in my house. Bluetooth operates in the 2.4GHz band ... and it appears for me that being connected to the 802.11g network was angering it. I switched to the 802.11n network and things started working nicely again.

So suggestion: try a 5GHz wireless network or a wired connection ... or simply turning off WiFi to test and confirm if you have the same issue. I figure there are other problems you can run into with Bluetooth, but this is what was wrong for me...

0

Bluetooth and WiFi can interfere. On several devices there are recommendations to turn off Bluetooth while using Wi-Fi (for example, Vaio manuals). I had this problem on my new Macbook Pro after the first few hours of work, once that I started a "heavy " (several hours) transfer from the older laptop - using WiFi. The mouse disconnected every 1-4 minutes. After a few hours, once the transfer was completed, the mouse started to work fine, again. On normal network use, this should not happen. But that was a good occasion to discover the new Force Touch Trackpad that is actually brilliant..

0

What did not work for me were the bluetooth/airdrop approach, rebooting, cleaning contacts, changing batteries, deleting bluetooth from Networks.

What seems to have done the trick was to fold a post-it and stick it between batteries and the cover (so the batteries can't move).

0

I too struggled with this disconnecting problem for many weeks trying every solution I could find including upgrading to "El Capitan". I gave up in the end and reverted to using my "Targus Bluetooth Laser mouse" Then an idea came to me. Previously when using the Targus mouse all other bluetooth mice (I also have a "Mighty Mouse") have been turned off. So I thought why not try the Targus and Magic mouse at the same time. Here is the sequence. Turn OFF Magic Mouse Turn on and connect Targus mouse Turn ON Magic Mouse Leave Targus on while testing the Magic for maybe a few hours (whatever you feel happy with) When satisfied all is well turn the Targus OFF. For me now all is perfect with the Magic so after a few more hours I decided to RESTART my Mac, (Leave Magic turned on and other mice off) Magic started straight away on restart and has stayed working perfectly for 5 days now. I did intend to test this routine with the Mighty Mouse but as all is happy I did not want to push my luck but I feel that if you have or have access to any other bluetooth mouse then this should work. I really hope this works for you...

0

I have Magic Mouse II (because the original Magic Mouse did the disconnect/reconnect thing). Main differences: +$10 and rechargeable built in. i.e., there is no access to the battery. BTW, adding spacers to the battery would not have been an issue as my mice disconnect and reconnect while sitting idly by the MacBook Pro.

Result with the new mouse: same problem. I guess I shall return to the Genius who "gave" me the new mouse but armed with some of the responses seen here. Mainly worried about WiFi interference. Working from home I need both wireless systems on.

0

Have one additional mouse with the cable. First go to System Preferences -> Mouse, set up Bluetooth mouse, click your mouse, remove it. Then turn Wi-Fi off. Then search for mouse again and Mac will find it. Now it works!

You must log in to answer this question.