150

I would like to have macOS Notification Center notifications on my left monitor and not my right monitor. It's hard to see them when I'm looking at the left monitor (since they're all the way on the right side and they're rather large monitors).

Is there any way to keep the screens in this order, but have the notifications appear on the screen I want them to appear on?

0

3 Answers 3

244

You should be able to do this by choosing the monitor on which the menu bar is active.

Try:

  • System Settings -> Displays -> Arrangement

and drag the little white bar to the monitor where you want the notifications to show up.

In the picture below, the bar is being dragged from the left to the right window.

Arrangement window with mouse

15
  • 70
    Wow this isn't at all obvious. Commented Aug 24, 2017 at 17:59
  • 17
    This works, of course, but it also causes the (⌘-Tab) Application Switcher to move to that monitor. Is there a way to change the location of only notifications? Commented Sep 8, 2017 at 14:08
  • 5
    Oddly, the cmd-tab selections appear only on the Macbook Pro's screen, while the notifications are on the primary screen (the one with the white bar)
    – wrlee
    Commented Jul 11, 2018 at 21:35
  • 9
    @wrlee to switch where teh cmd-tab selections appear, on the display where you want them to appear, mouse over the dock on that display. That effectively switches where cmd-tab list shows up.
    – JohnQ
    Commented Apr 17, 2019 at 12:39
  • 5
    Yeah unfortunately this moves the menu bar, which I don't want to move. There really should be some way to move just the notifications.
    – karfus
    Commented Sep 11, 2019 at 8:24
39

In case you have mirrored displays and you have no notifications appearing on either screen, you might have fallen victim of the "DO NOT DISTURB - Enabled while mirrored" setting.

To change this setting, open the notification centre on the right, scroll up in the list to reveal the hidden settings panel, and toggle the DO NOT DISTURB switch.

do not disturb

On macOS Monterey, this setting has moved to System Preferences > Notifications:

System Preferences Notifications - Allow Notifications

On macOS Ventura, this is where you find it:

macOS Ventura Notifications

This setting also affects applications like OBS Studio when a Display Capture source is active.

3
  • 1
    WOW, why is this setting enabled by default? This was the fix in my case
    – lacy
    Commented Nov 17, 2020 at 21:01
  • 2
    I'm pretty sure the reason is to prevent notifications from private conversations from popping up when people are presenting their screen for work! The Zoom video conferencing app also turns on DND by default when screen sharing. Commented Feb 25, 2021 at 2:34
  • Thank you very much! I had the same issue while using the software "Duet Display" that allows one to use an iPad as a second screen.
    – Tafkadasoh
    Commented Apr 25, 2022 at 16:09
-1

The notification side-tray should appear on the screen which your cursor is currently positioned; it need not be the screen with the active menu bar... I've found that it isn't always consistent, and sometimes appears on whichever screen it last appeared. I was able to sync it up to the expected behavior by opening and closing the tray from the menu bar icon rather than trackpad gesture.

1
  • 4
    This appears to be untrue in Catalina. Notifications appear always on the same screen, regardless of which one is in focus.
    – oarfish
    Commented Feb 10, 2021 at 8:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .