0

enter image description here

What steps will reproduce the problem? 0. Using RubyMine 1. Use IdeaVim 2. Hold down "e" to auto-repeat end of word 3. Hit a : at end of word 4. See picture! I can pick lots of strange "e" characters.

What is the expected result? This should not happen. How to turn this off?

Cross reported here: https://youtrack.jetbrains.com/issue/RUBY-16003

However, I think this is a Mac issue, as this just happened after the recent upgrade.

  • This might fix the issue: defaults write -g ApplePressAndHoldEnabled -bool false However, this was not necessary before. Probably a way to set this in the app! – justingordon Nov 19 '14 at 18:01
  • I don't think so - that's a system-level popup (note how it doesn't follow the RubyMine theme). The defaults command you gave should indeed kill it off. – Mikey T.K. Nov 19 '14 at 18:37
  • I wonder if this as something to do with this weeks Yosemite big update? – justingordon Nov 19 '14 at 22:49
  • This is a Mac feature, yes. If you want the software you are using to disable that popup, you would need to address this with the developer of the software (as you appear to have done). There is nothing we can do to resolve it. – tubedogg Nov 20 '14 at 5:09
  • 1
    This question appears to be off-topic because it is a feature request for specific non-Apple software. – tubedogg Nov 20 '14 at 5:10
2

Aside from the author of the software addressing this, the following command turns off the press and hold, bring up the e's:

defaults write -g ApplePressAndHoldEnabled -bool false

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .