1

I try to setup up bower on my Mac Pro.

Info:

  • Mac OS X 10.9.5
  • node v0.10.5
  • npm 1.2.18

The command i use is:

 sudo npm install -g bower

The install doesn't work and i get the following error:

    Last login: Tue Nov 18 16:31:37 on ttys001
wutianzhitekiMacBook-Pro:~ wutianzhi$ sudo npm install -g bower
Password:
npm http GET https://registry.npmjs.org/bower
npm http 304 https://registry.npmjs.org/bower
npm http GET https://registry.npmjs.org/bower-config
npm http GET https://registry.npmjs.org/abbrev
npm http GET https://registry.npmjs.org/archy/0.0.2
npm http GET https://registry.npmjs.org/bower-json
npm http GET https://registry.npmjs.org/bower-endpoint-parser
npm http GET https://registry.npmjs.org/bower-logger
npm http GET https://registry.npmjs.org/cardinal/0.4.0
npm http GET https://registry.npmjs.org/bower-registry-client
npm http GET https://registry.npmjs.org/chalk/0.5.0
npm http GET https://registry.npmjs.org/chmodr/0.1.0
npm http GET https://registry.npmjs.org/decompress-zip/0.0.8
npm http GET https://registry.npmjs.org/fstream
npm http GET https://registry.npmjs.org/fstream-ignore
npm http GET https://registry.npmjs.org/glob
npm http GET https://registry.npmjs.org/graceful-fs
npm http GET https://registry.npmjs.org/handlebars
npm http GET https://registry.npmjs.org/inquirer/0.7.1
npm http GET https://registry.npmjs.org/insight/0.4.3
npm http GET https://registry.npmjs.org/is-root
npm http GET https://registry.npmjs.org/junk
npm http GET https://registry.npmjs.org/lockfile
npm http GET https://registry.npmjs.org/lru-cache
npm http GET https://registry.npmjs.org/opn
npm http GET https://registry.npmjs.org/mout
npm http GET https://registry.npmjs.org/p-throttler/0.1.0
npm http GET https://registry.npmjs.org/osenv/0.1.0
npm http GET https://registry.npmjs.org/promptly/0.2.0
npm http GET https://registry.npmjs.org/request-progress/0.3.0
npm http GET https://registry.npmjs.org/retry/0.6.0
npm http GET https://registry.npmjs.org/rimraf
npm http GET https://registry.npmjs.org/q
npm http GET https://registry.npmjs.org/nopt
npm http GET https://registry.npmjs.org/mkdirp/0.5.0
npm http GET https://registry.npmjs.org/request
npm http GET https://registry.npmjs.org/shell-quote
npm http GET https://registry.npmjs.org/semver
npm http GET https://registry.npmjs.org/stringify-object
npm http GET https://registry.npmjs.org/tmp/0.0.23
npm http GET https://registry.npmjs.org/tar-fs/0.5.2
npm http GET https://registry.npmjs.org/update-notifier/0.2.0
npm http GET https://registry.npmjs.org/which
npm http 304 https://registry.npmjs.org/abbrev
npm http 304 https://registry.npmjs.org/bower-endpoint-parser
npm http 304 https://registry.npmjs.org/bower-logger
npm http 304 https://registry.npmjs.org/bower-registry-client
npm http 304 https://registry.npmjs.org/bower-config
npm http 304 https://registry.npmjs.org/cardinal/0.4.0
npm http 304 https://registry.npmjs.org/archy/0.0.2
npm http 304 https://registry.npmjs.org/chmodr/0.1.0
npm http 304 https://registry.npmjs.org/fstream
npm http 304 https://registry.npmjs.org/fstream-ignore
npm http 304 https://registry.npmjs.org/glob
npm http 304 https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/decompress-zip/0.0.8
npm http 304 https://registry.npmjs.org/handlebars
npm http 304 https://registry.npmjs.org/chalk/0.5.0
npm http 304 https://registry.npmjs.org/is-root
npm http 304 https://registry.npmjs.org/junk
npm http 304 https://registry.npmjs.org/insight/0.4.3
npm http 304 https://registry.npmjs.org/lru-cache
npm http 304 https://registry.npmjs.org/inquirer/0.7.1
npm http 304 https://registry.npmjs.org/lockfile
npm http 304 https://registry.npmjs.org/opn
npm http 304 https://registry.npmjs.org/promptly/0.2.0
npm http 304 https://registry.npmjs.org/mout
npm http 304 https://registry.npmjs.org/osenv/0.1.0
npm http 304 https://registry.npmjs.org/bower-json
npm http 304 https://registry.npmjs.org/request-progress/0.3.0
npm http 304 https://registry.npmjs.org/q
npm http 304 https://registry.npmjs.org/nopt
npm http 304 https://registry.npmjs.org/rimraf
npm http 304 https://registry.npmjs.org/mkdirp/0.5.0
npm http 304 https://registry.npmjs.org/retry/0.6.0
npm http 304 https://registry.npmjs.org/request
npm http 304 https://registry.npmjs.org/semver
npm http 304 https://registry.npmjs.org/stringify-object
npm http 304 https://registry.npmjs.org/shell-quote
npm http 304 https://registry.npmjs.org/tmp/0.0.23
npm http 304 https://registry.npmjs.org/tar-fs/0.5.2
npm http 304 https://registry.npmjs.org/which
npm http 304 https://registry.npmjs.org/update-notifier/0.2.0
npm http 304 https://registry.npmjs.org/p-throttler/0.1.0
npm http GET https://registry.npmjs.org/supports-color
npm http GET https://registry.npmjs.org/has-ansi
npm http GET https://registry.npmjs.org/strip-ansi
npm http GET https://registry.npmjs.org/ansi-styles
npm http GET https://registry.npmjs.org/escape-string-regexp
npm http GET https://registry.npmjs.org/string-length
npm http GET https://registry.npmjs.org/chalk
npm http GET https://registry.npmjs.org/configstore
npm http GET https://registry.npmjs.org/latest-version
npm http GET https://registry.npmjs.org/semver-diff
npm http GET https://registry.npmjs.org/object-assign
npm http GET https://registry.npmjs.org/os-name
npm http GET https://registry.npmjs.org/tough-cookie
npm http GET https://registry.npmjs.org/async
npm http GET https://registry.npmjs.org/chalk
npm http GET https://registry.npmjs.org/configstore
npm http GET https://registry.npmjs.org/lodash.debounce
npm http GET https://registry.npmjs.org/inquirer
npm http GET https://registry.npmjs.org/throttleit
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/bower/node_modules/.bin'
npm ERR! error rolling back  bower@1.3.12 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/bower/node_modules/.bin']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: '/usr/local/lib/node_modules/bower/node_modules/.bin' }
npm ERR! Error: No compatible version found: request@'^2.40.0'
npm ERR! Valid install targets:
npm ERR! ["0.10.0","0.8.3","0.9.0","0.9.1","0.9.5","1.0.0","1.1.0","1.1.1","1.2.0","1.9.0","1.9.1","1.9.2","1.9.3","1.9.5","1.9.7","1.9.8","1.9.9","2.0.0","2.0.1","2.0.2","2.0.3","2.0.4","2.0.5","2.1.0","2.1.1","2.2.0","2.2.5","2.2.6","2.2.9","2.9.0","2.9.1","2.9.2","2.9.3","2.9.100","2.9.150","2.9.151","2.9.152","2.9.153","2.9.200","2.9.201","2.9.202","2.9.203","2.10.0","2.11.0","2.11.1","2.11.2","2.11.3","2.11.4","2.12.0","2.14.0","2.16.0","2.16.2","2.16.4","2.16.6","2.18.0","2.19.0","2.20.0","2.21.0","2.22.0","2.23.0","2.24.0","2.25.0","2.26.0","2.27.0","2.28.0","2.29.0","2.30.0","2.31.0","2.32.0","2.33.0","2.34.0","2.35.0","2.36.0","2.37.0","2.38.0","2.39.0","2.40.0","2.41.0","2.42.0","2.43.0","2.44.0","2.45.0","2.46.0","2.47.0","2.48.0"]
npm ERR!     at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:685:10)
npm ERR!     at /usr/local/lib/node_modules/npm/lib/cache.js:607:10
npm ERR!     at RegClient.get_ (/usr/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:101:14)
npm ERR!     at RegClient.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:37:12)
npm ERR!     at fs.js:266:14
npm ERR!     at Object.oncomplete (fs.js:107:15)
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/semver/head.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/semver/head.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/semver/head.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, open '/usr/local/lib/node_modules/bower/node_modules/mout/random.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/mout/random.js
npm ERR! code ENOENT
npm ERR! errno 34
npm http 304 https://registry.npmjs.org/supports-color
npm ERR! Error: ENOENT, chown '/usr/local/lib/node_modules/bower/node_modules/tmp/test/file-test.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/tmp/test/file-test.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/tmp/test/file-test.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call chown
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:305:19
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:222:7
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, open '/usr/local/lib/node_modules/bower/node_modules/bower-registry-client/lib/register.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/bower-registry-client/lib/register.js
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! Error: ENOENT, open '/usr/local/lib/node_modules/bower/node_modules/fstream-ignore/test/read-file-order.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/fstream-ignore/test/read-file-order.js
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/decompress-zip/lib/extractors.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/decompress-zip/lib/extractors.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/decompress-zip/lib/extractors.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/cardinal/examples/highlight-string.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/cardinal/examples/highlight-string.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/cardinal/examples/highlight-string.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/escape-string-regexp
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/bower-json/test/test.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/bower-json/test/test.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/bower-json/test/test.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/retry/test/integration/test-retry-operation.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/retry/test/integration/test-retry-operation.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/retry/test/integration/test-retry-operation.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http GET https://registry.npmjs.org/read
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/fstream/lib/dir-writer.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/fstream/lib/dir-writer.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/fstream/lib/dir-writer.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/string-length
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/inquirer/lib/prompts/checkbox.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/inquirer/lib/prompts/checkbox.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/inquirer/lib/prompts/checkbox.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http GET https://registry.npmjs.org/mkdirp
npm http GET https://registry.npmjs.org/pump
npm http GET https://registry.npmjs.org/tar-stream
npm http 304 https://registry.npmjs.org/chalk
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/q/q.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/q/q.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/q/q.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/request/request.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/request/request.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/request/request.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/configstore
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/handlebars/coverage/coverage.json'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 13.4.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/wutianzhi
npm ERR! node -v v0.10.5
npm ERR! npm -v 1.2.18
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/handlebars/coverage/coverage.json
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/handlebars/coverage/coverage.json
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/latest-version
npm http 304 https://registry.npmjs.org/semver-diff
npm http 304 https://registry.npmjs.org/ansi-styles
npm http 304 https://registry.npmjs.org/object-assign
npm http 304 https://registry.npmjs.org/os-name
npm http 304 https://registry.npmjs.org/has-ansi
npm http 304 https://registry.npmjs.org/chalk
npm http 304 https://registry.npmjs.org/tough-cookie
npm http 304 https://registry.npmjs.org/lodash.debounce
npm http 304 https://registry.npmjs.org/configstore
npm http 304 https://registry.npmjs.org/async
npm http 304 https://registry.npmjs.org/inquirer
npm http 304 https://registry.npmjs.org/throttleit
npm http 304 https://registry.npmjs.org/mkdirp
npm http 304 https://registry.npmjs.org/tar-stream
npm http 304 https://registry.npmjs.org/read
npm http 304 https://registry.npmjs.org/pump
npm http GET https://registry.npmjs.org/mute-stream
npm http 304 https://registry.npmjs.org/strip-ansi
npm http 304 https://registry.npmjs.org/mute-stream
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/wutianzhi/npm-debug.log
npm ERR! not ok code 0
wutianzhitekiMacBook-Pro:~ wutianzhi$ 

What's wrong with it?

1 Answer 1

1

I think the answer may be here:

rm -rf /usr/local/lib/node_modules
brew uninstall node
brew install node --without-npm
echo prefix=~/.node >> ~/.npmrc
curl -L https://www.npmjs.com/install.sh | sh

Make sure it's on your PATH:

export PATH="$HOME/.node/bin:$PATH"

Now try:

npm install -g some_package

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .