1

I have an external disk connected to MacBook via USB. From time to time the system alerts that the disk is unreadable, but sometimes it seems to connect and I can browse it in Finder, and even open some of its files with Quick Look, but some folders became empty although the disk has the same amount of free space. The Disk Utility can't repair the disk with alert: couldn’t unmount volume for repair. How can I possibly restore my data? My computer is MacBook Pro (early 2011), OSX Yosemite (10.10). The disk has its own power adapter. I've tried Data Recovery app, but it doesn't see the disk file system and can't scan it, while at the same time I can open some files on the disk in Finder... I also need to force eject the disk because it never ejects normally.

I've tested the disk with the case and power adapter which work for sure (with another HD).

This is how it looks in Disk Utility when the disk is unreadable

Disk information

Disk information

  • I have seen this happen when the external power supply is failing to provide enough power for the drive. But it could also be a symptom of a failing disk. – douggro Nov 19 '14 at 8:20
  • I'm using the power adapter and external disk case from another disk that works, so I'm sure that the problem is in the HD itself. – Kostsei Kuolematon Nov 19 '14 at 15:47
  • Failing drive is the first suspect. It's failing to read the partition map when the YYY partition doesn't show. Could be a marginal block in that area. Recover the data you can when the partition mounts, then reformat and repartition which will map out bad blocks. How old is the drive in question? – douggro Nov 19 '14 at 20:43
  • The disk is about 2-3 years old. I'm interested only in the data, but the most important files are not shown even when the disk mounts. I've tried a few data recovery apps but they either don't see it, either can't unmount it the same way as Disk Utility. Could be there a way to save the data? – Kostsei Kuolematon Nov 21 '14 at 10:35
  • If data recovery apps aren't working, your options are limited. Professional data recovery service could recover it, but that's very expensive. – douggro Nov 21 '14 at 13:27
0

I have solved the problem connecting the disk directly via SATA, I didn't have a Macintosh to install a 3.5" disk into, so I connected it to a PC with Windows 7, installing the HFS+ drivers, which allowed PC to see the disk and read (but not write) the data on it. I was able to copy the data to another external disk which I formatted into exFAT, so it could be used with OSX and Windows both. I still don't understand what was the problem with the disk, but I saved the important data, so I consider the problem solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .