4

I have an early Early 2011 MBP, which I installed 16GB of RAM in, despite the fact that Apple claims the maximum is 8GB. This is a hack which is known to work, but I'm having some trouble with hibernate as a result.

It seems my sleep image is only 8GB, despite the fact that my RAM is 16GB; consequently, if I lose power while having more than 8GB in memory, safe sleep fails.

Any ideas on how to correct this?

  • so you found the reason why Apple said 8 and not 16 :) – Ruskes Nov 19 '14 at 1:53
  • But it's just an arbitrary software difference, so it can be altered. – awiebe Nov 19 '14 at 11:06
  • @awiebe Did you ever figure out a solution? I just got a 2012 MBP that came with 16 GB of memory instead of 8 and have the exact same sleep image issue. I'm using 10.9.5. – iwantmyphd May 19 '18 at 18:39
  • @awiebe I also notice that the system takes a while to come back from sleeping (with the little white lozenges as the progress bar). It appears to be going into "Hibernation" mode, even if I have that setting disabled. I believe it is because the system wants to save all 16 GB of memory to disk (I have an SSD, not an HDD), but the sleep image is set to 8 GB, so the system is unable to use "Safe Sleep". Any ideas? – iwantmyphd May 30 '19 at 20:38
2

A guess

See whether the problem is reproducible with compressed memory disabled.

If that's not a workaround, please vote down this answer and leave a comment.

Related

vm_compressor_mode (vm.compressor_mode) values for enabled compressed memory in OS X

– there's a link to an answer about disabling compressed memory.

| improve this answer | |
  • That works unfortunately performance degrades, I'm trying different vmCompressor modes. – awiebe Dec 12 '14 at 20:16
0

I have exactly the same configuration (MacBook Pro Early 2011 16GB/10.7.5 though) and my sleepimage has full 16 GB size.

Just delete it by opening Terminal (located in /Applications/Utilities), and typing in the following command, followed by the enter key:

sudo rm /private/var/vm/sleepimage

Enter your administrator password (it will not be visible) and hit the enter key again.

Your Mac will automatically rebuild it when needed (hopefully with the correct size).

| improve this answer | |
  • Nope already tried that one. – awiebe Dec 10 '14 at 19:31
  • @awiebe which system? – klanomath Dec 10 '14 at 19:40
  • @klanomath I have the same problem and tried it with 10.9.5. – iwantmyphd May 19 '18 at 18:37
0

Recently I experiment a lot with disabling memory compression in Mavericks and I had clearly reproducible problems with hibernating to disk.

1) Enable memory compression and using an hibernate mode that writes to disk works without problems

vm_compressor=4 + hibernatemode=3(RAM powered+sleepimage) or 25(only sleepimage) 
-> no problem when restored from sleepimage

2) Disable memory compression and using an hibernate mode that writes to disk leads to kernel panics when waking up.

vm_compressor=1 + hibernatemode=3(RAM powered+sleepimage) or 25(only sleepimage) 
-> kernel panic when restored from sleepimage

3) Disable memory compression and using an hibernate mode that NOT writes to disk works fine.

vm_compressor=1 + hibernatemode=1(only RAM powered) 
-> no problem, as long you have enough battery power 
to prevent lost of RAM while sleeping

Well 3) is only a compromise since it lets you disable the memory compression, but you will loose the safety of the sleepimage.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .