10

I have the problem that occasionally on startup, icons are missing from the menu bar. This includes e.g. Clock, User name, Wi-Fi, Menu Meters and Notification Center. It does not apply to e.g. Little Snitch, lastfm, Spotlight and Watts. So it is not an issue of OS X versus other apps.

It looks like this:

enter image description here

This phenomenon appeared with Yosemite.

  • try log in as different user to check if it is your profile. – Ruskes Nov 18 '14 at 20:50
15

Although I do not know the problem, there are several solutions.

  1. Reboot or Log out.
  2. Kill the SystemUIServer process, either via Activity Monitor or via killall SystemUIServer. The UI server will restart and the problem will be gone. I've seen it happen that I needed to kill it twice to fully take effect.
  • THanks!! this worked and saved me a lot of time from rebooting every time – reidisaki Aug 27 '15 at 15:36
  • 1
    quitting SystemUIServer immediately did the trick (OS X 10.12.4). – Demis Apr 27 '17 at 5:18
  • Brilliant! Thank you. Option 2 is much better than restarting the whole thing from scratch! – rinogo Sep 1 '17 at 15:54
  • It doesn't help for my one drive icon(s) (10.13) – ohcibi Oct 18 '17 at 9:30
5

I thought I'd add that I had this issue again in Yosemite 10.10.3. A disk repair, 10.10.3 download & reinstall, deleting SystemUI preferences .plist, etc. had no effect for me.

What did work is a simple Safe Mode boot. No actual changes in Safe Mode, simply booting into it fixed my system menu bar icons. A reboot back into normal mode still had them fixed.

You can access Safe Mode by holding Shift right after the chime during startup.

-3

If you write killall SystemUIServer in terminal it will fix it!

  • 1
    This is no different that the accepted answer from several years ago. If you have additional, updated, or different info, please add it to your answer. – fsb May 7 '17 at 6:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .